Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Worried there's a leak in the winter cover - First time opening

  1. Back To Top    #1

    Join Date
    Apr 2013
    Location
    Central Massachusetts
    Posts
    174

    Worried there's a leak in the winter cover - First time opening

    I've been pumping water off the solid plastic cover in preparation for opening. I noticed the water on top of the cover was 2ft+ deep in the center of the cover. Not quite as deep on the the sides. I thought the center would come up as I pumped up water. I've pumped maybe a foot off. I feel like the water level on top of the edges is getting close to where I drained to when closing, but the center hasn't gotten much shallower. It may still be 1.5 feet deep.

    So now I'm worried something is wrong. Either the pool is leaking (which it didn't all summer and fall) or perhaps there's a hole somewhere in the cover (I couldn't find one that was obvious, but it could be under leaves) and water from the pool is leaking onto the top of the cover.

    What do you guys think? Is this normal and I should keep pumping? Or should I immediately stop pumping water out and handle this cover removal in a different way?

    Photos:
    Attached Images Attached Images
    26,000 gal 18x36' IG Vinyl Pool - Hayward S244T Sand filter - Hayward Tri-star 2-speed 1.5HP pump - Goldline Aqua Plus SWCG and Controller with Tcell-15 - Aquacomfort 125K BTU Heatpump - Hayward Color Comfort 4.0 LED - Zodiac MX8 suction cleaner - TF100 test kit
    My Build thread

  2. Back To Top    #2

    Join Date
    Apr 2013
    Location
    Central Massachusetts
    Posts
    174

    Re: Worried there's a leak in the winter cover - First time opening

    Update: I spoke with my PB and he explained that I likely did lose water due to displacement. We had a lot of precipitation this winter (12-18" liquid) and the water could have been pushed up high enough in the skimmer to leak into the ground. He recommended pumping the water from the cover into the pool as it hasn't been warm enough for anything to grow in it. I could optionally chlorinate the water on the cover for a couple days. I'll probably do that.
    26,000 gal 18x36' IG Vinyl Pool - Hayward S244T Sand filter - Hayward Tri-star 2-speed 1.5HP pump - Goldline Aqua Plus SWCG and Controller with Tcell-15 - Aquacomfort 125K BTU Heatpump - Hayward Color Comfort 4.0 LED - Zodiac MX8 suction cleaner - TF100 test kit
    My Build thread

  3. Back To Top    #3
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: Worried there's a leak in the winter cover - First time opening

    I think I would get rid of it if I had the choice.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •