Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Leaking Pump

  1. Back To Top    #1

    Join Date
    Jun 2011
    Location
    Central Iowa
    Posts
    105

    Leaking Pump

    Hi everyone. We got our pump new last August. Hayward "Voyager Swim Pro" or I think is a Power-Flo Matrix. This spring it is leaking out the bottom of the pump pretty good. Seem to be where the motor connects to the basket part. Noticed it a bit yesterday while I was vac/backwashing but really increased today as I was vac/backwashing again. Now it appears to be leaking even on the low speed.
    Once yesterday while I was cleaning I did let the pressure go up to 20-21 from beginning pressure of 15. The outflow was pretty poor from the return so I backwashed. Well since then the leaking has gotten worse. Did that one time of increased pressure cause this?
    Is this just a shaft seal and or housing O ring issue? I'm a bit surprised that we're having this problem already with such a new pump. Any thoughts?

    Thanks!
    27' x 54" AG Morada RTR/19,300 gal/ 1hp-2spd Hayward Power-Flo Matrix/Hayward 256T sand filter

  2. Back To Top    #2
    Smykowski's Avatar
    Join Date
    Sep 2011
    Location
    Gurnee, IL (North Suburban Chi-town)
    Posts
    3,065

    Re: Leaking Pump

    Most leaks like the one you describe turn out to be a bad shaft seal. I don't know the likelihood of getting a bad seal on a new pump, though.
    33' round, 23,000 gal AG vinyl , 1HP 2spd PowerFlo Matrix downsized with 3/4HP impeller (X2), Hayward S180T 150# sand filter (X2), Hayward H250 NG heater Pool Store year 1 - $850 for 2 months; Pool Store year 2 - $440 for 2 months, TFPC year 1 - $170 for 4 months; TFPC year 2 - $95 for 4.5 months
    The most important article on this site - The ABCs of Pool Water Chemistry

  3. Back To Top    #3

    Join Date
    Jun 2011
    Location
    Central Iowa
    Posts
    105

    Re: Leaking Pump

    Hi, just wanted to follow up. I picked up a new shaft seal kit at local pool store yesterday for $20 and hubby replaced it last night. Our pool was about ready to overflow with all this rain. He says leak has stopped on the pump but I'll keep an eye on it again tonight when I get home. I just wanted to say thanks!! My husband was stressed out with construction of our deck and now I told him the pump was leaking.....this site is invaluable! I may pick up a go-kit online just to have on hand for cases like these.
    I spoke with pool store folks and they mentioned that maybe my PH got too low since the seal went out so fast...I don't remember letting it get too low but thought I would add what they told me. They said that low PH will impact those seals.....
    27' x 54" AG Morada RTR/19,300 gal/ 1hp-2spd Hayward Power-Flo Matrix/Hayward 256T sand filter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •