Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Lay - Z Spa heater . No pump / E02 error

  1. Back To Top    #1

    Lay - Z Spa heater . No pump / E02 error

    I have a Lay-Z spa from 2012. It's the platinum/vegas version with the heater that can only heat or bubble, not both at the same time.

    The pump worked for just over a year, only need occasional cleans, but it's now in a state where whilst the BUBBLES work fine, the pump itself won't pump around water to filter.
    After power on, if the filter/heater setting is selected I get a few seconds of silence then beeps with E02 displayed

    E02 seems to be a water flow issue.

    I tried backflushing - in fact I can squirt water through either way around, and it comes out the other end just fine (in->out or out->in)

    At no point is there ANY noise.

    This suggests to me that the pump has failed/has bad connection
    If it was the flow meter I suspect it would pump for a while then stop.

    I've dismantled the unit but it's not clear what to check. The large "pump" unit seems clear of debris -- but thinking about it now perhaps this is just the air blower
    Where is the pump in this unit?
    Any recomendations on getting a spare part?

    I feel a little guilty posting about this cheap temporary unit here. One day I'll invest in a proper spa.... this one I acquired from someone who no longer wanted it!

    many thanks

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Houston, Texas

    Re: Lay - Z Spa heater . No pump / E02 error

    Bumping post to add it to today's activity stream. Hopefully someone will have suggestions for you.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts