Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Intellichlor IC40 attached to Easy Touch Control Panel

  1. Back To Top    #1

    Join Date
    Apr 2014
    Location
    North Carolina
    Posts
    2

    Intellichlor IC40 attached to Easy Touch Control Panel

    Good afternoon -

    I am a new pool owner through the virtue of purchasing a home that had an existing pool. Neither me or my wife know anything about pools so here I am. The pool and related equipment is approximately 5 years old and the system appears to be all Pentair products. We have a Intellichlor IC40 SWG connected to an Easy Touch control panel. Up until earlier today everything appeared to be working correctly.

    I had a gentleman come out today to do some maintenance on the pool and while doing so he turned off the breakers in the Easy Touch Control Panel. Now that they have all been turned back on, the IC40 is not functioning at all. No lights are on and the light on the Control Panel is not illuminated. The small circuit breaker button does not appear to be tripped and the cords/wires have not been touched. It sure seems like there is no power getting to the device but I cannot understand why. Also, when I go into the settings on the Control Panel and look at the Chlorine generator it has a message that says something like "not communicating" and "may wait 5 minutes." These may not be the exact words but hopefully someone that has experience with this particular combination will know what I am referring to. Oh yeah, everything else appears to be working correctly.

    Does anyone have any thoughts on what may have taken place? Thanks very much!

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Intellichlor IC40 attached to Easy Touch Control Panel

    It sounds like the power supply for the SWG is not getting AC power, or has blown a fuse (less likely). I would test the AC power connection at the SWG power supply with a multi-meter to make sure power is present, and if not trace it back to see where the fault is. If power is present, there are a couple of fuses inside the power supply that need to be checked.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Apr 2014
    Location
    North Carolina
    Posts
    2

    Re: Intellichlor IC40 attached to Easy Touch Control Panel

    Thanks very much for the advice. This really has me stumped.

  4. Back To Top    #4
    Divin Dave's Avatar
    Join Date
    Oct 2013
    Location
    Longview, Texas
    Posts
    4,926

    Re: Intellichlor IC40 attached to Easy Touch Control Panel

    The fuse for the power supply is on the bottom of it, back right corner. Sort of hidden by the power cable.
    Divin Dave,
    IG Vinyl, 15' x 30', 3 1/2' - 6' deep, Oval, ~15K gal, Intelliclor IC40, Intelliflo VS pump, Clean and Clear 420 Filter, auto-fill-disabled, Retrofit LED Color Light, Dolphin Nautilus Robot, TF100 Test Kit, Taylor K1766 Salt Test Kit, Tftestkit Pressure Gauge.
    www.tftestkits.net Experience- it's what's learned just after you needed it most !!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •