Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: DE all over my pool!!!

  1. Back To Top    #1

    Join Date
    May 2008
    Location
    Northern Cailfornia
    Posts
    5

    DE all over my pool!!!

    Hi friends,

    So I am a fairly new pool owner, things have been going okay with my pool.

    It seems like every other week there is a new issue.

    This past weekend I cleaned my DE filter following instructions from TFP. did the detergent soak and acid soak. Greatly improved the pressure of filter. I thought that all was well until....

    I woke up the next morning, looked in my pool, and there is a layer of DE on the bottom of the pool! I swept and scrubbed, but now I can literally see the DE coming back into the pool via the input water from filter. Other than that, I can definitely tell that the filter is working otherwise- the water clarity had vastly improved, except for all the DE.

    My first thought is that there is a hole in one of the filter cartridges. Does anyone have any other ideas for what could have gone wrong- and how to fix it?

    Please help! Is my only option to buy new filter cartridges? Any idea the lifespan of these?

    Thanks everyone!
    26,000 gallon inground pool & separate spa
    DE filter
    solar heater

  2. Back To Top    #2
    mtheaded's Avatar
    Join Date
    Oct 2007
    Location
    Lovettsville, VA
    Posts
    46

    Re: DE all over my pool!!!

    If you have DE returning to the pool from the return jets you have a hole in one of your filter grids for sure. Really couldn't be anything else, sorry to say.
    26,000 gallon IG Vinyl Lined, Hayward DE2400 Filter, Hayward SP2610X15 1/2 HP pump, Dolphin Sprite robot, open May to October

  3. Back To Top    #3

    Join Date
    Jun 2008
    Location
    Houston, TX
    Posts
    68

    Re: DE all over my pool!!!

    I had the same problem when I first moved into my house. The water was always cloudy. I finally figured out that if I turned off the polaris the water would clear up but I had a thick layer of dust on the bottom of the pool. I took the filter apart and viola - 5 of the 8 elements were bad. After I replaced those I had to vacuum all of the DE to waste as my polaris would not pick it up.
    Pool Specs:
    16,000 gal. IG - Plaster - Auto Chlorinator
    FNS 48 DE Filter - 2HP Centurion Pump (A.O. Smith)
    Hayward HeatPro Heat Pump - Polaris 360

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: DE all over my pool!!!

    Torn grids are a very likely cause, but it is also possible that the filter was not put back together properly. Make sure all of the grids/fingers are in the correct places and fully seated inside the filter and that you didn't leave any parts out when you put it back together.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5

    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,160

    Re: DE all over my pool!!!

    Welcome to TFP!!

    One other thought is that either the manifold that holds the grids is cracked or that the fabric that is supposed to cover the sleeves that fit into the manifold are not properly in place. Then again, as I think about it, the o-ring that is on the standpipe that the manifold sits on could be gone or pinched. These are the other things not already mentioned which could cause the same problem.

    Looks like you'll have to take the filter back apart and check for anything that we've mentioned

    Please keep us informed as to the results
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  6. Back To Top    #6

    Join Date
    May 2008
    Location
    Northern Cailfornia
    Posts
    5

    Re: DE all over my pool!!!




    Thank you all for your help!

    We took the filter apart and there was a connection problem with one of the grids.
    So far the DE is clearing out but the filter was cleaned on sunday and we've go some algae. How should we treat this?

    Thanks all
    26,000 gallon inground pool & separate spa
    DE filter
    solar heater

  7. Back To Top    #7
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: DE all over my pool!!!

    This Pool School article is a good place to learn about fighting algae.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •