Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: need help with my sand filter

  1. Back To Top    #1

    need help with my sand filter

    I have a new sand filter this season, which has been working great until yesterday. I noticed that the pump basket was not completely full, which happens when the pressure increases and it needs backwashed, but the pressure gauge reads pressure of only 1. I also noticed that there are some bubbles coming out of the return jet, so there is air getting in the line somehow. I backwashed and everything is still the same. Pressure of 1, flow is a little better, but not much, bubbles in the jet. Usually backwashing increases the return jet pressure in a huge way. Any suggestions? I can't figure out where air would be entering the line either - tightened the pump basket lid and checked everything, but couldn't find any problems.

    Thanks!

    Erin
    27' AG round pool; vinyl liner; 1 HP pump; 40 GPM Tagleus sand filter

  2. Back To Top    #2

    Re: need help with my sand filter

    Maybe you have a blockage somewhere...either between skimmer and pump or pump and filter? Have you vacuumed recently? My psi dropped to 5 one time (usually runs 15) and I was having to prime the pump because the basket was only half full of water.....the problem was that my kreepy krawly sucked up some leaves/goo which went passed the pump basket and was in the opening between the pump and filter. I had felt that opening and didn't feel anything and then went back and pushed in a little further and felt the goo. I dug it out, and the psi went back up and the air worked itself out of the system and is now working fine. Hopefully it is a simple fix for you like it was for me.
    [i][color=#BF0040]27' x 52"....1.5 HP hayward pump 200lb sand filter.....finally building our deck :)

  3. Back To Top    #3

    Re: need help with my sand filter

    thanks for the idea. You know, now that you say that, I ran the auto cleaner yesterday and there were goggles and things in the pool that I tried o get all fished out before I ran it, but maybe I missed something, b/c the timing is right for that to be it!!

    Off to check now,

    Erin
    27' AG round pool; vinyl liner; 1 HP pump; 40 GPM Tagleus sand filter

  4. Back To Top    #4

    Re: need help with my sand filter

    That must have been the problem; I took apart the line from the pool to the pump and flushed it out and now it is working fine. I didn't see anything come out of the line except water, but it's working, so who cares! Thanks again for the idea!!
    27' AG round pool; vinyl liner; 1 HP pump; 40 GPM Tagleus sand filter

  5. Back To Top    #5

    Re: need help with my sand filter

    No problem....I remember that I was frenzied trying to figure out what had happened to drop my psi all of a sudden.....I was sooo happy when I figured it out and fixed it without needing the hubby
    [i][color=#BF0040]27' x 52"....1.5 HP hayward pump 200lb sand filter.....finally building our deck :)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •