Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Low Flow after Pebble Tec

  1. Back To Top    #1

    Low Flow after Pebble Tec

    Recently had the pool refinished (PebbleTec) and after refill the flows are sluggish. Pressure washed the filter, no change. I am wondering if there is a bunch of debris from the resurfacing in the return or outflow to pool. anyone ever heard of this?

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Houston, Texas

    Re: Low Flow after Pebble Tec

    Do you have a main drain?
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Low Flow after Pebble Tec

    What is your filter pressure normally, and what is it now? That will help narrow down the problem.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4

    Re: Low Flow after Pebble Tec

    Also, if you can post a full set of chemistry readings, that would help us diagnose the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts