Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: pool pump priming every startup

  1. Back To Top    #1

    pool pump priming every startup

    Been working on a multitude of issues.... all but one has been solved.
    Have a pool with flow-over spa attached. Every time the pool starts up in the a.m. the pump has to self-prime. Although the pump is designed to do so, it still is extra wear and tear on the equipment.
    I can finally say there are no WATER leaks in the system. Does anyone have any suggestions to isolate where the air can be leaking into the system when there is no drippage? I have a pump / filter / heatpump / salt system.... in that order. Again, no moisture around any of these items - with the exception of the heatpump only when it is running. Thanks in advance.

  2. Back To Top    #2
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    SW Indiana

    Re: pool pump priming every startup

    More than likely it's a leak before the pump. Check out the article on Suction Side Leaks

    You probably have a smaller leak. Suction leaks sometimes seal under the vacuum from the pump.

    How high is your pump above the pool water surface?
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts