Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Filter woes

  1. Back To Top    #1

    Join Date
    Jul 2013
    Location
    El Centro, CA
    Posts
    3

    Filter woes

    So I'm in a bit of a pickle.

    I've got a pentair fns 60 DE filter that isn't filtering DE when I add it or very fine dust particles, which we get every time its windy here (2-3 times per week) so over the last few weeks my pool has gotten very dirty. The vacuum bag is too coarse to pick this up.

    I can hear air bubbles inside the filter and upon dissasembly, cleaning and inspection the only problem seems to be that the internal air bleeder assy is torn. The grids all look okay. Should replacing this fix my problem or is there more to it?

    Thanks.
    20k gallon, IG plaster, DE cartridge filter, 2HP single speed pump, Unkown build date (probably 70's), kleenmachine robot vacuum

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: Filter woes

    It could be the problem, but that wouldn't pass a terribly lot of DE back to the pool. I'd tear it apart and not only inspect the grids very carefully, but also the manifolds and seals. It doesn't take a large tear in a grid to pass a lot of DE/dirt.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Jul 2013
    Location
    El Centro, CA
    Posts
    3

    Re: Filter woes

    You hit the nail on the head.

    I cleaned the filter and inspected the cartridges and there was a small spot on the bottom of one about an inch and a half long where the stitching had come undone. I restitched it with upholstery thread and my pool is now clean again. It was amazing how much dirty water passed through that small tear.
    20k gallon, IG plaster, DE cartridge filter, 2HP single speed pump, Unkown build date (probably 70's), kleenmachine robot vacuum

  4. Back To Top    #4
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Filter woes

    Nice work ...

    You really have to look closely at these things as you discovered.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •