Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Motor stuck when removing

  1. Back To Top    #1

    Join Date
    May 2010
    Location
    Dallas, TX
    Posts
    227

    Motor stuck when removing

    I feel like I am missing something. Undid the four 9/16 bolts, and the motor won't pull away. Feels like it is stuck to the bottom of the front of the stand. Is there a bolt Iim missing?[attachment=1:3d8x542m]ImageUploadedByTapatalk1390066467.433011.jpg[/attachment:3d8x542m][attachment=0:3d8x542m]ImageUploadedByTapatalk1390066477.766583.jpg[/attachment:3d8x542m]
    Attached Images Attached Images
    new house: TBDK gal IG plaster pool, filter Titan CM DE filter 36 sq ft , 1.5 HP Pump; Polaris 380

  2. Back To Top    #2

    Re: Motor stuck when removing

    To change the motor, you remove the band clamp. (The big round silver clamp with the bolt sticking out.).

  3. Back To Top    #3

    Join Date
    May 2010
    Location
    Dallas, TX
    Posts
    227

    Re: Motor stuck when removing

    Quote Originally Posted by JamesW
    To change the motor, you remove the band clamp. (The big round silver clamp with the bolt sticking out.).
    Thanks. That was the issue

    . Now I'm stuck on the impeller screw. Can't loosen using my biggest flat head. Just slips out and don't want to strip it. Any tips? [attachment=0:1hafffnk]ImageUploadedByTapatalk1390073411.306332.jpg[/attachment:1hafffnk]
    Attached Images Attached Images
    new house: TBDK gal IG plaster pool, filter Titan CM DE filter 36 sq ft , 1.5 HP Pump; Polaris 380

  4. Back To Top    #4

    In the Industry

    JoshU's Avatar
    Join Date
    May 2007
    Location
    New Orleans, LA
    Posts
    541

    Re: Motor stuck when removing

    . Now I'm stuck on the impeller screw. Can't loosen using my biggest flat head. Just slips out and don't want to strip it. Any tips?
    It is a reverse thread screw.
    Josh Ulfers - josh@saltpoolguys.com - 888-725-8766
    SaltPoolGuys.com - AutoPilot Pool Pilot Systems, Parts & Cells - AquaCal Heat Pumps

  5. Back To Top    #5
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Location
    Lakeland, FL
    Posts
    2,351

    Re: Motor stuck when removing

    17K Kidney Shaped Pool Concrete (Diamond Bright) Pool, 3/4 hp 2 speed 115V Sta-rite Duraglas PEA5D-180L/P2R5D-181L (Impeller C105-92PS Diffuser C1-216P), 1.5 piping, Pentair CC100 Filter , Heat Siphon 100K BTU Heat Pump Pool Heater, Flow meter Blue White Flowmeter Model No. F-30150P, Hayward Astrolight SP0581N, SWCG CalimarTitanium Edition TE45 , Dolphin Nautilus Plus with CleverClean, Lakeland Florida

  6. Back To Top    #6

    Join Date
    May 2010
    Location
    Dallas, TX
    Posts
    227

    Motor stuck when removing

    Yeah, I found the manual, just says to unscrew it clockwise as it's reverse threaded.

    Found this old thread:
    sta-rite-dura-glas-impeller-screw-is-stuck-t52611.html

    Will try those fixes. I just can't get a good enough grip and a big enough flat head to get it loose. It's always something when messing with pool equipment!
    new house: TBDK gal IG plaster pool, filter Titan CM DE filter 36 sq ft , 1.5 HP Pump; Polaris 380

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •