Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: broken hot tub?

  1. Back To Top    #1

    broken hot tub?

    Hello

    My wife and I are in the process of selling our house with a hot tub. I believe it is a gecko m-class (MSPA-1).
    Anyway, a buyer was having an inspection of the property by a home inspector a couple days ago. This guy decided to show her how to work the tub. Their agent says he couldn't get it to turn off so he just started mashing buttons till it did. Well now the control panel is showing the numbers p1 2. I think this is a error code for pump failures. It was working properly before the inspection, and the reason he couldn't get it to turn off is probably because it was filtering or heating.

    Is there anything I can do? or just force them to fix it?

    Thank you

  2. Back To Top    #2
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: broken hot tub?

    I don't know how much success you'll have, but it is certainly worth a try. Sounds like they could be the culprits, but I think it will
    be hard to convince the powers that be to pay for it. I do wish you luck and would certainly exhaust that option if it were me.

    Welcome to TFP Jarker!
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  3. Back To Top    #3

    Re: broken hot tub?

    They were definitely the culprits lol. I know it was working when i left the house, I come back after the inspection and it's broken.

    Reading more on this p1 2 thing... I think they switched it into programming mode. On these if you hold the on/off button for 20 seconds it sends it into that mode. You have to continue hitting on/off to cycle through the selections before it resets itself. However, the on/off buttons doesn't seem to be doing anything. Now i'm thinking it's more of a broken control panel from this guy mashing the thing trying to get it to work

    PS they are trying to get me to pay for half of the repair lol

  4. Back To Top    #4
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: broken hot tub?

    I'd press them as hard as I could. At least half is better than none though if all else fails.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  5. Back To Top    #5

    Re: broken hot tub?

    Had a repair guy out today. He said the keypad was busted. Well at least replacing the keypad is the next step. If you unplug the control panel it heats and circulates

    Would really like to find the part online from a reputable dealer. The repair company is charging a lot more for the part and labor for plugging it in. But if it doesn't fix the problem they'll be there.

  6. Back To Top    #6
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: broken hot tub?

    Good deal, hope they get it resolved for you.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  7. Back To Top    #7

    Re: broken hot tub?

    Hey Jarker
    can you provide the 'MODEL' and 'OPTIONS' numbers off your spa pack? I can cross-reference them for you and see what the replacement topside controller will be. Also, please attach a picture or dimensions of your topside.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •