Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: AquaLink needs an exorcism!

  1. Back To Top    #1

    AquaLink needs an exorcism!

    I have a Jandy AquaLink RS One Touch Control System. (2006 Model 8158 with Firmware L).
    Last night (not during regular schedule) I noticed the pool filter was turning itself off and on every few seconds. I could not control it from the indoor (wired, not wireless) control panel. I ended up flipping the breaker to turn everything off.

    Today after work I turned everything back on and everything seemed good (including the date and time, so my 9volt battery is working).
    The filter ran fine for about 30 minutes until I looked out the window and noticed the filter was off. I looked at the control panel inside and it said the date was 08/04/04 (i think that was the date. I cut the power to the system to ultimately turn everything off) and that everything was off. I reset the date/time and filter ran good again for a few minutes.

    I again looked out the window and noticed the spa, spa heat and spa light was on as well as spa blower. (The spa switch hasn't worked in years so I disabled it in the system). The pool light began turning itself off and on, and the Polaris cleaner was moving around (booster pump on). The control panel inside said everything was turned off. I went outside and looked at the PCB and it said everything was also turned off.

    I ended up turning the breakers off and the gas to the heater to turn everything off.

    Does anyone know what's wrong? Is it the Power Control Board? If so, does anyone know the part number of the new compatible iAuqualink wireless panel that I can buy to replace this existing one, or is there something else wrong that I'm not catching?

    Thank you all for your help!
    Dallas, TX

  2. Back To Top    #2
    Divin Dave's Avatar
    Join Date
    Oct 2013
    Longview, Texas

    Re: AquaLink needs an exorcism!

    I cant help you out. No automation at my place....

    seems like your problems might be fitting for halloween though a day early.

    If it were me though, I would change the battery in any case, and if there is a way to do a master reset.......
    Divin Dave,
    IG Vinyl, 15' x 30', 3 1/2' - 6' deep, Oval, ~15K gal, Intelliclor IC40, Intelliflo VS pump, Clean and Clear 420 Filter, auto-fill-disabled, Retrofit LED Color Light, Dolphin Nautilus Robot, TF100 Test Kit, Taylor K1766 Salt Test Kit, Tftestkit Pressure Gauge. Experience- it's what's learned just after you needed it most !!

  3. Back To Top    #3
    pwrstrk's Avatar
    Join Date
    Aug 2012
    Elverson Pa.

    Re: AquaLink needs an exorcism!

    Welcome to TFP !
    I'm not an automation guru but somebody will be along to help you out.
    Enjoy the forum !
    24'x54" AG Morada RTR (by wilbar) 13'500 gal. Hayward Powerflo Matrix 1hp 2 speed. Hayward Perflex EC65 DE filter.

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: AquaLink needs an exorcism!

    Sounds like you might have gotten a power surge and it fried the board. I'd call Jandy and see what they say. Could be some reset you could try, but most likely a board replacement is in your future.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  5. Back To Top    #5

    Re: AquaLink needs an exorcism!

    I ran through diagnostics with Jandy. They had me reset the system completely... As soon as I turned the breaker back on the filter pump/heat/blowed/ and lights all came on. I can toggle both on the one touch inside and manually outside on the PCB and no matter what I try to turn off or on there is no response at all. Whatever is on stays on, and whatever is off stays off. They thing the board is fried. At least I can upgrade to the new one and enjoy iAqualink, right? Early Merry Christmas to us! I will report back once I buy one and install it to verify issues have been resolved. Thank you all for your tips and suggestions.
    Dallas, TX

  6. Back To Top    #6

    Join Date
    Jul 2007
    Allen, Texas

    Re: AquaLink needs an exorcism!

    Couple of things:

    1) Do you have a spa side switch? I see you mention disabling the switch.....but did you physically unplug it from the control board?
    2) Have you tried pulling the relay control wires from the control board? It's just a little 2 wire plug for each relay.....if you unplug it, the relay should open and the associated device (pump, blower, booster pump, etc) should stop working. This would confirm a wonky control board if plugging it back in causes the relay to activate (without you telling it to).

    Worsecase, you get to upgrade to iAqualink. That's what I did 3 weeks ago....nice upgrade with wifi, plus you get the latest firmware which allows control of variable speed pumps. If you are lucky enough that your sprinkler system control is nearby, you can move the sprinkler control wires to iAqualink and control your sprinkler system also (mine is 100+ feet away and no possibility of running new wires).

    16.5k IG gunite pool/spa, pebble-tec type plaster, Aquapure 1400 SWG, Jandy 2hp ePump main pump, Jandy 1.5hp Stealth on waterfall, Polaris 280, iAqualink wifi control, Colorsplash LED pool/spa lights

  7. Back To Top    #7

    Re: AquaLink needs an exorcism!

    Thanks for the tip. I never tried unplugging it because the tech I talked to said that since the panel displayed all features "off" and regardless of what I selected to turn "on" would result in no change that the PCB was pretty much toast. I remember when my spa side switch started to go that the spa would randomly turn on of off, however the One Touch Control panel and the PCB would reflect what options were on or off. I won't connect the Spa Switch when I put the new PCB in.
    I completely forgot that the iAqualink can control sprinklers! The sprinkler control box is actually on the same wall of the house as the pool equipment. I'd say they are about 30 feet apart. Maybe in the spring I will run the wires to the iAqualink through a conduit along the foundation of the house. Good Idea, thanks!
    Dallas, TX

  8. Back To Top    #8

    Re: AquaLink needs an exorcism!

    Well the PCB was the root cause of the problem. New one installed in about 5 minutes, another 5 for the iAquaLink and about 15 minutes to set up all of my labels, one touch programs, AquaPure, and regular programs. The only catch is the new PCB "ports" are in slightly different places than the previous, so some rerouting of wires withing the power center had to be done. No biggie. Thanks again to all for your input. By the way, iAquaLink is awesome!
    Dallas, TX

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts