Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: Sta-Rite Dyna-Glas Questions/Problems

  1. Back To Top    #1

    Join Date
    Oct 2013
    Location
    Jupiter, FL
    Posts
    19

    Sta-Rite Dyna-Glas Questions/Problems

    Greetings. This is my first post, so drinks are on me.

    I'm having a couple of issues with my 1HP Sta-Rite Dyna-Glas pump. I recently purchased a 7-year old home with a small pool, my first pool. Anyway, for the past few weeks when trying to start-up from the timer, the motor will hum for a few seconds, then shut off. I assume this is not normal. It will go through this cycle a number of times before finally turning-over. After it finally starts up, the pump runs fine and it has never actually failed to (eventually) start-up. If I try to turn the pump on manually in the morning, it also hums and will not turn over. However, if it's been running all day, I can manually turn the pump off and back on without a problem.

    I am able to reach in and spin the impeller. It appears to spin normally (or what I believe to be normally).

    My first thought is replace the start capacitor, since it's a relatively cheap and simple task. However, here is where the second issue comes into play: I'm having trouble removing the cover to access the motor/electrical end. It seems to only be attached by two screws and should just slide off, but the darn thing is really stuck on there! I fiddled with it a little (tried prying it off with a screwdriver), etc... but not wanting to damage anything, didn't go much further. Any advice on safely removing the cover? Also, would a failing capacitor produce the sluggish start-up? I friend told me that a capacitor either works or does not -- so perhaps I should be looking elsewhere for the start-up problem.

    Thanks in advance.

    (yes, I shut off the power at the circuit before doing any of this )
    18'x9', IG, Plaster, AutoPilot Pool Pilot Digital Nano SWG (RC-35/22 Cell), 1 HP Sta-Rite Dyna-Glas Pump, Sta-Rite PXC75 Posi-Clear Cartridge System, AquaCal Heatwave Heat Pump.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,345

    Re: Sta-Rite Dyna-Glas Questions/Problems

    Welcome to TFP.

    Once you have the screws out, (Make sure there isn't a third, under the bottom) the back cover just slides off. They do tend to get stuck and can take some pretty good raps to get it to move. I'd suspect the start contacts ("V" shaped device at the end of the shaft) aren't making good contact. You can clean them with very fine sand paper or an emery board. inspect them to make sure they're touching when the motor is stopped.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Oct 2013
    Location
    Jupiter, FL
    Posts
    19

    Re: Sta-Rite Dyna-Glas Questions/Problems

    Thanks. I'll give it a try and report back.
    18'x9', IG, Plaster, AutoPilot Pool Pilot Digital Nano SWG (RC-35/22 Cell), 1 HP Sta-Rite Dyna-Glas Pump, Sta-Rite PXC75 Posi-Clear Cartridge System, AquaCal Heatwave Heat Pump.

  4. Back To Top    #4

    Join Date
    Oct 2013
    Location
    Jupiter, FL
    Posts
    19

    Re: Sta-Rite Dyna-Glas Questions/Problems

    Cover came off after giving it a couple of "raps". Perfect description... thanks for the help.

    As for the sluggish starting, the contacts were clean and making good contact (I still gave them a little bit of the business with an emery board). I also removed the motor to be sure there were no obstructions in the impeller. It was clean. Tried to turn the pump on manually a few times and it would not turn over. Walked away and noticed the pump turned itself on from the timer (after about 10 minutes of false startups).
    18'x9', IG, Plaster, AutoPilot Pool Pilot Digital Nano SWG (RC-35/22 Cell), 1 HP Sta-Rite Dyna-Glas Pump, Sta-Rite PXC75 Posi-Clear Cartridge System, AquaCal Heatwave Heat Pump.

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,345

    Re: Sta-Rite Dyna-Glas Questions/Problems

    Sounds like a bearing problem. Does it make noise when running?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6

    Join Date
    Oct 2013
    Location
    Jupiter, FL
    Posts
    19

    Re: Sta-Rite Dyna-Glas Questions/Problems

    No. I've never heard any noises. The motor is relatively quiet and smooth when running.
    18'x9', IG, Plaster, AutoPilot Pool Pilot Digital Nano SWG (RC-35/22 Cell), 1 HP Sta-Rite Dyna-Glas Pump, Sta-Rite PXC75 Posi-Clear Cartridge System, AquaCal Heatwave Heat Pump.

  7. Back To Top    #7
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,345

    Re: Sta-Rite Dyna-Glas Questions/Problems

    I misread your earlier statement. I thought you'd tried to manually turn the shaft. Now I see that you manually flipped the switch, as it were.

    It could be the capacitor. Have you replaced it yet?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  8. Back To Top    #8

    Join Date
    Oct 2007
    Location
    Valrico, FL
    Posts
    536

    Re: Sta-Rite Dyna-Glas Questions/Problems

    I second replacing the capacitor. The start capacitor is only used during starting, once the motor is at speed it is disconnected. So if you have a bad capacitor (reduced capacitance and increased leakage) then starting torque is reduced, resulting in motor not starting sometimes. The reason the motor hums for a period and then stops is the integral thermal overload in the motor is tripping and then resetting. This is not good for the motor as it over heats the windings and will result in their premature failure.
    7,500 gal, IG pool, L shape 22' x 15', 1.5 hp pump, cartridge filter, AquaPlus SWG/Controller, Pebble-Tec liner.

  9. Back To Top    #9

    Join Date
    Oct 2013
    Location
    Jupiter, FL
    Posts
    19

    Re: Sta-Rite Dyna-Glas Questions/Problems

    Thanks for your help. Yes, when I say "i tried to turn it on manually" I meant flipping the switch to "on" at the timer.

    The motor did not turn on today so I cut the power completely so that it wouldn't keep trying. I ordered a new start capacitor and tune-up kit (shaft seal, assorted o-rings) and will report back its condition once installed.

    What a great site! Glad I found it. I've read and learned a lot from the place already.
    18'x9', IG, Plaster, AutoPilot Pool Pilot Digital Nano SWG (RC-35/22 Cell), 1 HP Sta-Rite Dyna-Glas Pump, Sta-Rite PXC75 Posi-Clear Cartridge System, AquaCal Heatwave Heat Pump.

  10. Back To Top    #10

    Join Date
    Oct 2013
    Location
    Jupiter, FL
    Posts
    19

    Re: Sta-Rite Dyna-Glas Questions/Problems

    Success! After 3 days off waiting for parts, I got the pool back up and running. Put in a new start capacitor, shaft seal, diffuser o-ring, seal plate o-ring, and lid cover o-ring. I also used the downtime to give my cartridge filter a good overnight soak in dishwasher detergent and water. Fired right up with good flow / prime. Cost me about $50 total but feel like I serviced the motor and hopefully will get some extra time out of it.

    Frankly, I'm not 100% positive that the capacitor was bad (didn't test with the multimeter). After taking the motor apart to remove the impeller, it seemed more likely that the starter switch was not making good contact with the governor. That's probably what bama was trying to tell me in the original response. Either way, I'm happy that it's running and learned a lot about the pump and motor.

    Thanks again for the help!
    18'x9', IG, Plaster, AutoPilot Pool Pilot Digital Nano SWG (RC-35/22 Cell), 1 HP Sta-Rite Dyna-Glas Pump, Sta-Rite PXC75 Posi-Clear Cartridge System, AquaCal Heatwave Heat Pump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •