Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Letro Legend II problems

  1. Back To Top    #1

    Letro Legend II problems

    I have a letro legend II and the back end is sticking up. The back wheels will not set flat on the pool surface. Any tips would be greatly appreciated.

  2. Back To Top    #2
    midtngal's Avatar
    Join Date
    Oct 2007
    Location
    Nashville, TN
    Posts
    485

    Re: Letro Legend II problems

    Hi djbee761! Welcome to TFP! I too have a Letro. You will need to play around with the jets on the back a little. They probably need to be pushed up some. A very little amount of change will make a big difference so don't over do it.

    Hope that helps!

    Karen
    10,700 gal IG vinyl
    Pentair Triton II TR50 sand filter
    Hayward SharkVac XL cleaner; Emerson 1HP pump
    Bioguard Mineral Springs SWG
    2 skimmers

  3. Back To Top    #3

    Re: Letro Legend II problems

    OK, thanks for the advice but this happens even while the pump is not running . The back end is up off of the bottom.
    Thanks.

  4. Back To Top    #4

    In the Industry
    Qwaxalot's Avatar
    Join Date
    Jun 2012
    Posts
    439

    Re: Letro Legend II problems

    Quote Originally Posted by djbee761
    I have a letro legend II and the back end is sticking up. The back wheels will not set flat on the pool surface. Any tips would be greatly appreciated.
    Try sliding the ballast float (the egg shaped thing sticking out of the mast) forward a little bit.
    In the industry, CSP (Certified Service Professional) by the NSPI and it's successor the APSP. My company services over 600 pools every year. I think the practices regularly espoused on this forum (especially the BBB method) are outstanding; however my comments will be often oriented towards the goal of getting it done, and getting it done right now!

  5. Back To Top    #5

    Re: Letro Legend II problems

    I pushed it up all the way and still have the same problem.

  6. Back To Top    #6
    midtngal's Avatar
    Join Date
    Oct 2007
    Location
    Nashville, TN
    Posts
    485

    Re: Letro Legend II problems

    Are you talking about when it's not on? Mine does that sometimes but I don't worry about it. If it's doing that while it's on, then that is when an adjustment to the valves in the back or the ballast float will correct that. Otherwise, it's no big deal.
    10,700 gal IG vinyl
    Pentair Triton II TR50 sand filter
    Hayward SharkVac XL cleaner; Emerson 1HP pump
    Bioguard Mineral Springs SWG
    2 skimmers

  7. Back To Top    #7

    Re: Letro Legend II problems

    Ok thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •