Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Spa is not blowing bubbles

  1. Back To Top    #1

    Join Date
    Sep 2013
    Location
    San Diego, California
    Posts
    20

    Spa is not blowing bubbles

    Guys - I have a problem with my spa. It's an inground spa connected to my pool built about 10 or 11 years ago. On occasion in the past it has stopped bubbling. The company who built the pool advised that the spa nozzles sometimes come loose and there was probably one that just needed tightening. This always worked, it was always the same nozzle and a quick tighten restored the spa to full function.

    About a month ago it happened again I went to tighten the nozzle but it wasn't loose. So I checked others and they all seem fine.

    Does anyone have a clue what might be wrong? I'm not sure how these things work. I have six jets and there seems to be good flow through all of them. The water heats fine, just doesn't have the spa jet bubbling thing.

    Any thoughts or advice would be very welcomed.

    Many thanks.
    1) 14,000 gals
    2) DE filter
    3) In ground
    4) concrete
    5) Flow rate of filter; 120

    Location - San Diego, California

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,490

    Re: Spa is not blowing bubbles

    Have you checked the air vent for any blockage? Also, does your system use a blower and is it in working order?
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  3. Back To Top    #3

    Join Date
    Sep 2013
    Location
    San Diego, California
    Posts
    20

    Re: Spa is not blowing bubbles

    thanks, there is a vent and it's not blocked. I don't know if I have a blower but I don't see anyhting
    1) 14,000 gals
    2) DE filter
    3) In ground
    4) concrete
    5) Flow rate of filter; 120

    Location - San Diego, California

  4. Back To Top    #4
    bmann71's Avatar
    Join Date
    Aug 2007
    Location
    Washington, Indiana
    Posts
    55

    Re: Spa is not blowing bubbles

    Here are a few steps you can try that I found online a few months ago.


    1. Review the control panel. Make sure all jets you want to use are turned on. Spas with multiple motors may have multiple jet settings that create bubbles in the water.

    2 Check all jets to make sure they are open and free from clogs.

    3 Clean the filter. Dirty spa filters will restrict water flow and result in no bubbles.

    4 Unclog any water and air intakes. Keeping your spa's system clog free is essential to air and water flow in your spa.

    5 Increase the water level of the spa. Low water levels will allow the spa to suck in air unnaturally into the filter. This can result in improper flow of water and air in the spa.

    6 Open the valves inside the spa. Valves help move air and water through the internal plumbing of the spa. Partially or fully closed valves will restrict bubbles in the spa.

    7 Turn power off to the spa for 30 to 60 seconds. This can reset any minor electrical issues involving the pump or blower motor.
    Ponduke
    20,000 gal/ Fiberglass IG/ Sta-rite s7m120 cartridge filter/Sta-rite SR400NA 400,000 btu heater/Polaris 360 Cleaner/K-2006 Test Kit
    poolcalculator
    Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •