Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Water jets of Jacuzzi not working

  1. Back To Top    #1

    Water jets of Jacuzzi not working


    I'm new to the forum, a total jacuzzi-newbie and not a native speaker so excuse my possibly poor grammar .
    Yesterday we got our second hand jacuzzi delivered. It's a Sunrise spa of about 6 years old...
    Totay we filled it up to test it and it works beautifully, but one problem.
    The waterjets aren't working at all. When i push the button to activate them i hear a "click" in the pump-computer, but it doesn't do anything.

    We tried to let trapped air escape and I believe it's all out.

    What could be the cause of this?

  2. Back To Top    #2

    Join Date
    Mar 2012
    Tampa Bay, Florida

    Re: Water jets of Jacuzzi not working

    Probably a bad blower motor. It sounds like the circulating pump is working, but most spas that I am aware of have a seperate blower with it's own motor for the velocity jets.
    John (DIYer). Concrete, approximately 13,000 gallon inground pool with adjoining concrete spa. Approximately 35 years old. Legacy Anthony Sta-Rite bronze pump CF6, VA-26 filter,(2 sets), new Rheem propane heater for spa. HASA Liquidator for pool.

  3. Back To Top    #3

    Re: Water jets of Jacuzzi not working

    Is is possible that the jets don't work while heating the hut-tub? Maybe running both is taking up too much power?

  4. Back To Top    #4

    Re: Water jets of Jacuzzi not working

    Never mind, i's fixed
    The separate motor that controlls the jets didnt get any power.
    They put a separate switch in to fix that.

    Thnx anyway!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts