Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Question about pump noise and high filter pressure

  1. Back To Top    #1

    Question about pump noise and high filter pressure

    I've been hearing kind of a whining sound coming from my pump motor (Jandy Stealth 1.5hp). Initially, I thought it was the motor bearings beginning to fail. However, my filter pressure (Jandy CV340 cartridge), normally about 10psi is up to about 18psi. I cleaned the cartridges and replaced them, but the pressure is still 18psi. I noticed the pump is much more quiet at 0 pressure while it's priming, then the whining gets louder. Thinking the cartridges may need to be replaced, I removed them from the filter and started the pump. Still at 18psi. I did check the pump with a stethoscope and the motor housing is pretty quiet, however, the pump portion whines loud. I am assuming I have a blockage somewhere and when the pressure gets high, the impeller is making the noise trying to move the water. How can I determine where the problem lies?

    Thanks,
    Daron

    20k gallon gunite pool with a Jandy CV340 cartridge filter, Jandy Stealth 1.5hp single speed pump, T15 Salt Cell, Polaris 280 cleaner with booster pump.
    20k gal Gunite, diamond brite plaster, Jandy 340 cartridge filter, T-Cell 15 SWG, Jandy Stealth 1.5hp single speed pump, Polaris 280

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Question about pump noise and high filter pressure

    Does the gauge read 0 when the pump is off?
    If the gauge is fine, then sounds like you have a blockage (or closed valve) after the filter. Do you have multiple return paths to the pool?
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Re: Question about pump noise and high filter pressure

    Yes, as soon as I turn the pump off, the gauge reads 0. I have two return paths. One for the 5 pool returns and one that feeds my deck jets. I can't even imagine how they would get blocked. Just had another thought, I guess I need to check my salt cell for restriction.
    20k gal Gunite, diamond brite plaster, Jandy 340 cartridge filter, T-Cell 15 SWG, Jandy Stealth 1.5hp single speed pump, Polaris 280

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •