Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 18 of 18

Thread: Hayward Variable Speed Pump Drive Error Pump Has Stalled

  1. Back To Top    #1

    Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Hello,

    I'm in Cedar Park, TX (Outside of Austin) and had a pool put in last Winter (filled Feb, 2013). I have had pretty consistent issues with the Hayward Ecostar Variable Speed Pumps. I have a Pro Logic Panel that controls it.

    I continually have a Drive Error! Pump Has Stalled on the panel, and on the Pro Logic Controls the Check System light comes on, and the pump shuts off.

    I have been trying to find a resolution, and have been working with my builder Texas Pools and Patios who have been awesome. They are as stumped as I am, and Hayward has been working with us as well. I'm looking for anyone that may have seen this problem.

    I changed the Prime from Auto Sense to 3 Minutes that I saw on another thread.

    The strange thing is it usually occurs in the afternoons, during timer 3, and not in the morning. Hayward came out and suggested that we limit it to 2933 RPM vs full of 3450, saying the plumbing possibly can't handle. It seems to handle it fine all morning on Timer 1, it runs at 3450 without issue for 4 hours. I worked outside on the patio on the laptop all morning to watch, and it doesn't kick off.

    One other strange item, when it shuts down, I can use the remote, and as soon as I adjust the pump lower, it comes back one, immediately. Any help, if you have some, would be much appreciated.

    Regards,
    Jason
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Welcome to TFP.

    I haven't heard of that issue before. What does Hayward say causes that error? Surely the pump didn't actually stall.

    Which pump are you having trouble with?
    Is the pump is the sun in the afternoon?
    What is the filter pressure with it running at 3450?
    Is there any other equipment that starts during the afternoon that isn't running in the morning (i.e. Solar heater, water feature, etc.)?
    Is there a cleaner hooked to the pump?
    If so when is it scheduled to run?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Thank you for looking at this. I copied your questions and added my answers:



    I haven't heard of that issue before. What does Hayward say causes that error? Surely the pump didn't actually stall. **Hayward has replaced the Drive (not the motor) 3 times. They came out with my builder and programmed the Pro Logic to not let the pump go above 2933rpm (85%) and said that might solve the issue. I'm not pleased that I won't be able to run at 100%, and the pool builder agrees with me. Hayward said that sometimes there isn't enough plumbing and the pressure shuts down the pump. This is a pretty big builder in Austin, and they don't think that is the issue. Plus, the pump runs at 100% from 7am to 11am on Timer 1 with no problem.

    Which pump are you having trouble with? **Hayward Variable Speed Ecostar, it's the pool pump. I have two, one is setup completely separate just for our waterfall, overkill, but I haven't seen any issues with it. Plumbing is completely separated.
    Is the pump is the sun in the afternoon? **Yes, that side of the house gets the sun.
    What is the filter pressure with it running at 3450? **I am trying to attach a picture, but it is at 21 PSI, I just backwashed and cleaned filter, this is the standard pressure. I can turn valve to Bypass in front of the filter, and it still persists, so I don't see that the filter would be the issue.
    Is there any other equipment that starts during the afternoon that isn't running in the morning (i.e. Solar heater, water feature, etc.)? **No, I have no solar, and nothing else is running.
    Is there a cleaner hooked to the pump? **There is a cleaner, it runs from 7-9am, and has a separate booster pump, and the VSP Pump doesn't shut down during that cycle. The Cleaner doesn't run in the afternoon when I tend to have the issue.
    If so when is it scheduled to run? **7-9am


    **I will add, I have had the issue at some other times, just usually in the afternoon. In fairness, I live in TX, and it's very hot outside a lot of different times during the day.

    Frustrating issue. The drive has been replaced, but never the main motor. We've opened it up (I watched the builder) and spun the blade to confirm no obstructions.
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Running that pump at full speed is way overkill, but it still shouldn't have a problem.

    What size and length piping do you have running to the pool?
    How many returns do you have?
    How many skimmers do you have?

    When switching from filter to bypass the pressure should go down a little, so I'm a little concerned about that. Are you sure that the gauge is good?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  5. Back To Top    #5

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    I'll try and answer these the best I know:

    What size and length piping do you have running to the pool? **The couplings say 2" on the 90 degree, so I believe it's all 2", but I'm not 100% sure.
    How many returns do you have? **I have a spa/pool combo with spillover. One return looks to go to the pool, and a valve where some goes to the spa. In Spa mode, all goes to the Spa.
    How many skimmers do you have? **I have two skimmers and a main drain.

    When switching from filter to bypass the pressure should go down a little, so I'm a little concerned about that. Are you sure that the gauge is good? **I may have mis-communicated here. When I switch the front valve on the Filter to "Boost/Bypass" the pressure gauge on the top of the Filter runs at zero, so I know the water isn't passing through the filter. It does still spillover from the spa, so I know it's running full speed.
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  6. Back To Top    #6
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Can you post a pic of the equipment? Surely you have more than one return in the pool.

    Since it mostly happens in the afternoon, you may want to get a temp reading on the drive and the motor several times during the day. While it should be designed to take the heat, it'll give you an idea if heat is a factor. You could also fashion a temporary open roof over it and see if the problem still persists.

    Since your filter pressure is only running at 21 psi the pump you're not running on either edge of the curve.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  7. Back To Top    #7

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    This is the return area of the equipment. Hopefully this shows what you are looking to see.
    Attached Images Attached Images
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  8. Back To Top    #8
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Can you take one from a different angle? It's hard to tell how it's plumbed from that angle.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  9. Back To Top    #9

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    More of the equipment pictures. As far as distance, the equipment is on the side of the house toward the back, very close, on the spa side of the pool. You can see the corner of the house in the far end of the picture.
    Attached Images Attached Images
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  10. Back To Top    #10

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Skimmer and Main Drain to pump.
    Attached Images Attached Images
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  11. Back To Top    #11

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    One more pic
    Attached Images Attached Images
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  12. Back To Top    #12
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    I don't see anything that looks like it would cause a problem.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  13. Back To Top    #13

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Bama Rambler, I really appreciate you looking at this. You are no different than my Builder Texas Pools and Patios and Hayward (and both have bee great, I'm not bashing at all, I LOVE our pool) everyone says they've never seen a pump respond like this.

    Not great to have that kind of problem, ha.

    Going through my troubleshooting mind, I think I've covered a few items:

    1. The plumbing should be fine, and it runs during certain portions of the day at 100% without issue, which would tell me plumbing is fine.
    2. Communication is fine, because I can immediately turn the pump down to 85% when it stalls via the remote, through the Prologic 8, then the pump starts on its' own, immediately.
    3. My builder replaced the communication wire, thinking there might be a comm error, just in case.
    4. I adjusted, on the pump, the prime from Auto Sense to 3 minutes based on another thread, and it did not help.
    5. One thing that I find interesting, is that when it stalls, I can turn off filter pump and back on and it immediately starts again. I would think if overheated, it wouldn't start.
    6. Also fascinating, that when it stalls with Drive Error, I turn it down to 2933 RPM, and it immediately starts, what sensor would regulate this?
    7. This almost always happens right after I backwash. Yesterday, I ran a backwash cycle, then put in the DE powder (usually stalls during this process which is maddening) and this time it took 15 or 20 minutes and started stalling.

    It has also happened without doing this, but usually happens afternoon, which means heat could be the issue. Were you suggesting that I possibly throw up a shade of some sort to keep the sun off the equipment? That's a possibility.
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  14. Back To Top    #14
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    I was thinking shade of some sort but if it almost always happens after a backwash I'm not sure it is worth it. Unless you always backwash in the afternoon.

    Immediately after backwashing the pump is seeing as low a head as possible and it may be running out on the edge of the pump curve. If that's the case, then the drive could sense it and shut the pump down. Just because the error says it stalled doesn't mean that's what happened.

    Here's something to try. Adjust the return 3-way valve so that it partially blocks the common return line enough to raise the filter pressure a couple of psi. Let the pump run that way for a day or two and see if it shuts down again. If it doesn't then backwash the filter and see if it does it then.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  15. Back To Top    #15

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Bama Rambler,

    Thank you for the help.

    My pool builder finally convinced Haywared to replace the entire pump (vs. just the drive). It is running at 100%, and I have not had an issue since the replacement. They replaced the Drive twice, and said it would not be the pump itself. I'm not an expert on that, but at this point it has fixed the issue. I did a full DE backwash cycle, and did not have a problem, which is almost always when it occurred.

    Only concern I have is that here in Texas, the temps aren't still crazy hot, so that factor was fixed. I'm hoping the heat wasn't the issue. One other factor that I'm seeing, the new pump is noticeable quieter than the one replaced. Maybe I'm over thinking it, but I really believe it less of a high pitch whine to it. Either way it's fixed for now, and I appreciate you taking the time to help.
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  16. Back To Top    #16
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    The motor windings could have been the problem, but it would be rare. I'm glad they replaced it and now all is well.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  17. Back To Top    #17

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Update 1 Year Later:

    It has been a year, and the pump that was replaced has worked without issue. This seemed to be a fairly obscure issue, hope it doesn't happen to others.

    I really appreciate the help.
    Cedar Park, TX 25,000 gal free form pool spa combo, Wet Edge Satin Matrix Antigua bottom, 36'x17.5' dimensions
    Two Hayward Ecostar Variable, one for pool/spa, one for waterfall water feature, Texas Moss Rock 4 ton
    DE Hayward 6020 filter, 400k btu Hayward heater, Kreepy Krauly Cleaner, Hayward Pro Logic 8 Panel with remote, Hayward ColorLogic 4.0

  18. Back To Top    #18

    Re: Hayward Variable Speed Pump Drive Error Pump Has Stalled

    Hi People. First post.. but I'm having the same problem with my Hayward EcoPump model SP3400VSP. It's a litte less than 3 years old. The motor control panel says: Drive error, Pump has stalled. I've tried to reset everything, change speeds, turn off power, turn motor with allen wrench, clean filters... all no luck. Its installed in a warm but protected location. All motor control is executed from the integrated panel on the top on the pump, not from the Hayward pool computer. Maybe the cheapest option is just to replace it... maybe with a cheaper 2 speed or single speed pump? Thanks for any ideas and suggestions!



    Rough and Ready, CA. 20x50 in ground, plaster, 45,000 gallons, 400Kbtu sta rite propane heater, Polaris sweep, Aqua Matic hydraulic cover.
    Frank, Northern Ca. 45,000 gallon 1 year old 20 x 50 inground, white plaster, Aqua Matic automatic cover, 525 sq foot cartridge filter, 1.5 hp variable speed Hayward Pump, Nature in line chlorinator, Polaris Pool Sweep with 3/4 hp aux. pump. 400,000 BTU Sta Rite propane heater. All equpment located below actual pool surface elevation

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •