Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Air Switch/Valve controller not working

  1. Back To Top    #1

    Air Switch/Valve controller not working

    Total Newbie Here (pool owner for 2 months).

    The set up: A spa with an overflow waterfall into the main pool. There are 2 Jandy Valve Actuators (24VAC) that are controlled by an "air switch."

    We recently had a heater installed and for about 3 weeks everything was working normally. When the air switch was depressed, the valves would divert the flow from the pool to the hot tub jets and the heater would kick on. Now, nothing happens.

    The valve controller is probably at least 10 years old, and I was trying to troubleshoot it myself and avoid paying for repairs/electrician. The input is 240V to a 24V magnetic contactor and then to a 14 pin socket relay. The wires for the valve actuators are attached to the socket relay. Everything is wired according to the schematic (attached), but when the air switch is depressed, the only thing that seems to happen is that the magnetic contactor is activated.

    Is this a salvageable situation or should I just break down and spend $200+ on a new valve controller?

    Thanks in advance,
    Attached Images Attached Images
    15,000 Gallons
    Cartridge Filter
    Inground, pebble (diamondbrite?)
    Unknown filter specs

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Air Switch/Valve controller not working

    Since the air switch supplies power to the coils of both the contactor and the relay they should both actuate at the same time. Is that happening?

    If not, make sure power is getting to the coil of the relay.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: Air Switch/Valve controller not working

    Problem Solved!

    My father-in-law pointed out that pin 4 of the 14-pin connector had to be grounded (for some reason it wasn't, and worked initially).

    Once I grounded it, things work as they are supposed to.

    Thanks everyone, I am sure I will be seeking your help in the future. And maybe I will learn enough to help someone else.
    15,000 Gallons
    Cartridge Filter
    Inground, pebble (diamondbrite?)
    Unknown filter specs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts