Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Leak from backwash with new gasket?

  1. Back To Top    #1

    Leak from backwash with new gasket?

    Hello everyone, first post to TFP.

    Moved in to a new house 2 weeks ago, and we noticed a leak coming from the backwash hose on our Purex Triton tagelus ta100d sand filter. We opened up the filter, and noticed the spider gasket was ruined. We ordered a new one and installed it, and the channels where it sits were in good shape.
    However, there is still a small leak from the backwash.

    Things I noticed (not sure if they're relevant)
    After I turn the pump off, there seems to be suction from the backwash port for a minute. All the water also drains out from my pump if I change the multiport position.
    Also, my heater won't turn on (shows a lo error), which I think is from the reduced water pressure(filter psi gauge doesn't show anything)

  2. Back To Top    #2
    linen's Avatar
    Join Date
    Jul 2010
    Location
    Twin Cities, MN
    Posts
    8,649

    Re: Leak from backwash with new gasket?

    Welcome to tfp, Mtym

    If the new spider gasket is still in place (I would check it again), and the handle is seating correctly, I would guess the vavle spring is weak and might need to be replaced.
    TFP Expert who uses Pool School and my TF100 test kit along with PoolMath for my: Round 11K gallon AGP with deep end, 20" sand filter, Matrix 1hp 2spd, 6 2ftX20ft solar panels (and solar cover!), Intex SWCG (copper bars disconnected) and a Rubadub hot tub (chlorine). The SLAM process is not finished until: 1. CC < 0.5 ppm, 2. An OCLT < 1.0 ppm and, 3. The water is crystal clear.

  3. Back To Top    #3

    Re: Leak from backwash with new gasket?

    Okay, I will look at it. Is this probably the reason why my heater won't turn on?

  4. Back To Top    #4

    Join Date
    Aug 2012
    Location
    Herndon, Va
    Posts
    65

    Re: Leak from backwash with new gasket?

    Also, check the areas where the gasket meshes up to. I've seen these get damaged and and no seal, I assume from not pushing the handle down all the way when turning.
    ____________________________________________________________ _____
    IG 25,000 gallon concrete painted pool,
    KDI American Products Model# 583090 Titan SS Vertical Grid 48sq ft DE filter

  5. Back To Top    #5

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,082

    Re: Leak from backwash with new gasket?

    Okay, I will look at it. Is this probably the reason why my heater won't turn on?
    No...unrelated.

    Also probably unrelated to the heater, but if your psi is zero with the pump running (and you have flow) you need a new pressure guage.

    Can't help with the heater.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •