Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Polaris 380 Running Half-Speed

  1. Back To Top    #1
    CUTiger78's Avatar
    Join Date
    May 2009
    Location
    NoVA
    Posts
    460

    Polaris 380 Running Half-Speed

    Help! I'm getting about 16 RPM. I've checked all the obvious things:
    • Polaris booster pump rebuilt at the start of this season. Seems to be running OK.
      Cleaned in-line filter.
      Backup valve backs up & shuts off completely.
      Took the cover off & everything looks OK; all hoses connected.
      Seems to have normal pressure & flow out of the tail, directional jet, & 3 bag jets.
      Swivels don't seem to be leaking.


    Got any ideas?

    Thanks!
    36K gallon 42X22 gunite/plaster kidney-shaped IG;
    1 hp Hayward Super Pump (new in 2012);
    Hayward S244T sand filter w/ Zeosand (both new in 2009);
    175K BTU LAARS Lite2 LG natural gas heater; Polaris 380;
    TF-100 test kit.

  2. Back To Top    #2

    Join Date
    Jul 2012
    Location
    CA
    Posts
    240

    Re: Polaris 380 Running Half-Speed

    Do you mean the filter on the wall? When you unscrew hose from wall there is a little screen that gets clogged. If that's not it, has anyone messed with valves? maybe your not getting enough flow?
    25k I/G ecostar ccplus Polaris plaster

  3. Back To Top    #3
    CUTiger78's Avatar
    Join Date
    May 2009
    Location
    NoVA
    Posts
    460

    Re: Polaris 380 Running Half-Speed

    Quote Originally Posted by marty
    Do you mean the filter on the wall? When you unscrew hose from wall there is a little screen that gets clogged. If that's not it, has anyone messed with valves? maybe your not getting enough flow?
    Yep, the filter on the wall/in-line filter. That little screen is clean & clear.

    Nobody's messed with valves. Maybe I'm not getting enough flow, but I don't know how to attack that. There's no leakage at the relief valve, at any of the connections, and the swivels aren't leaking.
    36K gallon 42X22 gunite/plaster kidney-shaped IG;
    1 hp Hayward Super Pump (new in 2012);
    Hayward S244T sand filter w/ Zeosand (both new in 2009);
    175K BTU LAARS Lite2 LG natural gas heater; Polaris 380;
    TF-100 test kit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •