Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Sheer Descent No Suction to pump

  1. Back To Top    #1

    Sheer Descent No Suction to pump


    I have a two seperate Jandy Stealth pumps. The one that runs the filter work great. The other that runs the sheer descents seems to be working but I can't get it to fill up and prime. The pump runs and seems to sound OK. I've tried putting buckets of water and hose to get the circulation moving, but pump will run water through descents but I can't get new water to flow through suctions side.

    I don't know where to go from here. Any help would be greatly appreciated.

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Pleasanton, CA

    Re: Sheer Descent No Suction to pump

    Sounds like there might be a clog in the suction line or the impeller. Try the impeller first through the bottom of the pump basket. You can also try to back flush the suction line with a hose wrapped in a wet rag stuck into the suction pipe via the pump basket.
    Hydraulics 101; Pump Ed 101; Pump and Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, 1/2 HP 2sp pump, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater, ThePoolCleaner

  3. Back To Top    #3

    Re: Sheer Descent No Suction to pump

    Thanks Mark, I will give that a try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts