Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Bubbles in Return Getting Worse and Filter Partially Empties

  1. Back To Top    #1

    Bubbles in Return Getting Worse and Filter Partially Empties

    So we purchased a house with a pool last fall and have not had very many problems, however recently we've had the following problems:

    Our set up is as follows:

    Spa that over flows into pool.

    Our pad consists of the following:

    - 3 inflows (1 from hot tub and 2 from pool..........skiimmers (2) and drains (2)). Inflow from spa is turned off.
    - Inflows go through pump (pump has small air bubbles at the top, but nothing major) to DE filter
    - Out filter to heater then through a Venturi valve (oxygenator hooked up here). Don't know what the venturi does or what the setting needs to be on.
    - Through a tube set up that is supposed to add minerals
    - Back to the pool via the hot tub and jets in pool (set to send water to both).

    Recently I've noticed that upon start up we get a huge explosion of air out of the jets in the pool. They stop after a while, but then small bubbles continue.

    We've also noticed that occasionally the hot tub will lose some water over night and be about 2 inches lowere in the morning (pump not on at night).

    So last night I was looking at the set up and noticed that when the pump turned off, it sounded as if the filter was emptying water (I'm assuming towards the pool and then filling up with air...........but have no idea where the air can be coming in at).

    The air coming into the pool is starting to effect the Polaris unit effectiveness.

    Any thoughts.

  2. Back To Top    #2
    linen's Avatar
    Join Date
    Jul 2010
    Twin Cities, MN

    Re: Bubbles in Return Getting Worse and Filter Partially Emp

    Welcome to tfp, russinfortworth

    Do you have air in your pump basket when it is running? It sounds to me like you have air getting in on the suction side. Most common culprits are a leaky pump lid o-ring (lube it up good with silicone and/or teflon lube), leaking pump drain plugs, vortex in the skimmer due to low water level, or stuck skimmer weir door.
    TFP Expert who uses Pool School and my TF100 test kit along with PoolMath for my: Round 11K gallon AGP with deep end, 20" sand filter, Matrix 1hp 2spd, 6 2ftX20ft solar panels (and solar cover!), Intex SWCG (copper bars disconnected) and a Rubadub hot tub (chlorine). The SLAM process is not finished until: 1. CC < 0.5 ppm, 2. An OCLT < 1.0 ppm and, 3. The water is crystal clear.

  3. Back To Top    #3

    Re: Bubbles in Return Getting Worse and Filter Partially Emp

    2 bubbles about the size of a quarter in the top of the pump basket, they do not get bigger, but never clear either.

    I'll get some of the silicone tonight and see if that fixes it.

  4. Back To Top    #4
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: Bubbles in Return Getting Worse and Filter Partially Emp

    Are you able to purge the air out of the filter? That should be done any time you open the system. Do you see any water leaks on the pressure side? That would allow air in when the pump is off and let the filter drain.

    BTW, I would seriously recommend discontinuing the use of the mineral system ... the metal could cause staining and green hair and really provides very little benefit over chlorine.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts