Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: CircuPool problem

  1. Back To Top    #1

    Join Date
    Apr 2010
    Location
    Sunny Phoenix AZ
    Posts
    74

    CircuPool problem

    Hi team,

    So it was a few days since I went out and checked the pool....found all sorts of algae spots...went and check the SWG; and it was off completely.

    I toggled the system on/off a few times; unit stayed off. Thinking it may have overheated in the 115 degree weather recently, I let it cool off overnight but this morning, nothing.

    What is interesting is that if you press and hold in the Fuse Reset button on the bottom of the unit, it comes on and seems to be operating normally...until you let go of the button it shuts off immediately.

    Any thoughts on what might be wrong?
    28,000 gallons / Plaster / Hayward 30" Sand Filter / PoolCleaner 4x / PoolSkim / Hayward RS1500 / CircuPool RJ60

  2. Back To Top    #2

    Join Date
    Apr 2010
    Location
    Sunny Phoenix AZ
    Posts
    74

    Re: CircuPool problem

    One add: it is NOT working correctly when I hold down the breaker. It shuts off after about 30 seconds even if I keep holding the button.

    All wiring seems intact.
    28,000 gallons / Plaster / Hayward 30" Sand Filter / PoolCleaner 4x / PoolSkim / Hayward RS1500 / CircuPool RJ60

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: CircuPool problem

    Sounds like something causing an overload and tripping the breaker.
    If you unplug the cell does it still trip the breaker?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Join Date
    Apr 2010
    Location
    Sunny Phoenix AZ
    Posts
    74

    Re: CircuPool problem

    Quote Originally Posted by Bama Rambler
    Sounds like something causing an overload and tripping the breaker.
    If you unplug the cell does it still trip the breaker?
    There is no difference if the cell is unplugged or plugged in...
    28,000 gallons / Plaster / Hayward 30" Sand Filter / PoolCleaner 4x / PoolSkim / Hayward RS1500 / CircuPool RJ60

  5. Back To Top    #5
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Location
    Lakeland, FL
    Posts
    2,351

    Re: CircuPool problem

    Check you end cap connections to the cell. Make sure they're clean and tight.
    My unit had a similar problem (Compupool CPSC48) and my main board was shot. There are several resistors and the top 2 were fried. Nice toasty color. Compupool replaced my unit. From what I understand CircuPool is rebranded Compupool with some modifications??
    17K Kidney Shaped Pool Concrete (Diamond Bright) Pool, 3/4 hp 2 speed 115V Sta-rite Duraglas PEA5D-180L/P2R5D-181L (Impeller C105-92PS Diffuser C1-216P), 1.5 piping, Pentair CC100 Filter , Heat Siphon 100K BTU Heat Pump Pool Heater, Flow meter Blue White Flowmeter Model No. F-30150P, Hayward Astrolight SP0581N, SWCG CalimarTitanium Edition TE45 , Dolphin Nautilus Plus with CleverClean, Lakeland Florida

  6. Back To Top    #6

    Join Date
    Apr 2010
    Location
    Sunny Phoenix AZ
    Posts
    74

    Re: CircuPool problem

    Quote Originally Posted by bobodaclown
    Check you end cap connections to the cell. Make sure they're clean and tight.
    My unit had a similar problem (Compupool CPSC48) and my main board was shot. There are several resistors and the top 2 were fried. Nice toasty color. Compupool replaced my unit. From what I understand CircuPool is rebranded Compupool with some modifications??
    I removed and cleaned the contacts and reinstalled...still nothing.

    Sounds like I'm going to need to call these guys...
    28,000 gallons / Plaster / Hayward 30" Sand Filter / PoolCleaner 4x / PoolSkim / Hayward RS1500 / CircuPool RJ60

  7. Back To Top    #7
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: CircuPool problem

    I would call them, but it sounds like a board or transformer problem.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •