Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 3 of 3

Thread: Bestway Flowclear Chlorinator will not work

  1. #1
    Junior Member
    Join Date
    Jul 2013
    Posts
    2

    Bestway Flowclear Chlorinator will not work

    Hello! All!!

    I grabbed a Bestway Flowclear chlorinator last season and was in heaven!!! Works easy for newbies to salt pools and easy to maintain.....well till this year

    We had a big storm storm a couple weeks back (Toronto, Ontario and surrounding area) and we lost power. But on vacation so did not see to the issue right away. We lost power and it tripped the outside power outlet so pump and chlorinator

    Came home to icky pool!

    Shocked to remove icky green and turned on the filter and clorinator and nothing! the red power turns on and if you try to program it does alot of beeping but nothing.

    Cleaned out the cells and connections as per the guide but at a loss.

    Of course my year warranty was up in June and I am hoping there is some other troubleshooting someone can help me with before I have to bite the bullet and go back to chlorine

    Cindy

  2. #2
    Administrator JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    34,818

    Re: Bestway Flowclear Chlorinator will not work

    Welcome to TFP!

    The first thing to try is to check the connections between the cell and the main unit, and try turning the power off and back on again and see if that makes any difference.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    TFP Admin. Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. #3
    Junior Member
    Join Date
    Jul 2013
    Posts
    2

    Re: Bestway Flowclear Chlorinator will not work

    A few days later and I definately have to give Kudos to my Husband. Turns out the start button was not working - he now has the circuit board outside the machine and has to manually jump start the SWG with his electrically meter!

    Looking around to find this part now - but working great even though its guts are out wrapped in a freezer bag!

    Still cannot believe how rusted the circuit board was! definately not a good seal!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •