Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Costco Evolution Problems

  1. Back To Top    #1

    Costco Evolution Problems

    I purchased a costco evolution 110 jet Tub. Filled up, Powered Up, pumps functioned, Did not have Temp Reading on screen and there was a wrench on left side with the text FLO. Was working on it for an hour or 2 and the control panel died. I have 220 into main, bromine control still powered up, stereo system powered up, No control panel power. Any Ideas out there?

  2. Back To Top    #2
    nuklhed's Avatar
    Join Date
    Jul 2013
    Location
    Las Vegas, NV
    Posts
    47

    Re: Costco Evolution Problems

    Obviously a return is out of the question! First call the store and ask who the maker is - CostCo is just a reseller after all. Whoever makes the pool should respond well because they want to keep their relationship clean with such a major marketer.
    23,000g IG plaster, textured ceramic 'mock slate' tile and flagstone cascades. Three levels (upper wading 16" dp, other 3.5-ft slate cascade); two skimmers. New Ultraflex II. Pentair Intelliflo 3hp pump, 4-cartridge Hayward filter. Two other 2 hp Superpump II push water features (jets, cascade). Las Vegas, NV (desert enviro). Water temp: winter avg. 45f, summer avg. 86f. Water service: private well, TDS hard @ 250+pp, pool 770ppm!!

  3. Back To Top    #3

    Re: Costco Evolution Problems

    I tried to contact tech support, closed for weekend. Just wondering if this was a common problem or easy fix. Main pump stays running, circulating the water but not heating.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •