Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Polaris booster pump- quick connect broken off in pump intak

  1. Back To Top    #1

    Polaris booster pump- quick connect broken off in pump intak

    How do I remove the broken piece of the quick connect from the pump intake.
    Attached Images Attached Images

  2. Back To Top    #2

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Polaris booster pump- quick connect broken off in pump i

    Quote Originally Posted by Jwood7
    How do I remove the broken piece of the quick connect from the pump intake.
    I believe they make some type of spray you can spray on the similar to WD40. You could also try a two pair of channel locks if you have them. One on each side.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,337

    Re: Polaris booster pump- quick connect broken off in pump i

    Can you post a picture of the pump suction?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Re: Polaris booster pump- quick connect broken off in pump i

    Here's the photo of the broken piece.
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •