Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Booster Pump Making Strange Noise (Video)

  1. Back To Top    #1

    Join Date
    Jun 2013
    Location
    Dallas, TX
    Posts
    105

    Booster Pump Making Strange Noise (Video)

    Noticed that my booster pump was making a horrible noise today. Hoping it doesn't need replacement. Here's the video:

    http://f.cl.ly/items/3g352F1a42240V0y2j1o/IMG_2335.mov
    35k gal, sand, IG, diamond brite, Hayward Goldline T-CELL-15 Turbo SWG, Aquarite, Compool Lx3600

  2. Back To Top    #2

    Join Date
    Jul 2007
    Location
    Rockville, CA
    Posts
    99

    Re: Booster Pump Making Strange Noise (Video)

    Is your pool cleaner attached while the motor is running and making the horrific noise? When I remove my pressure side pool cleaner and hose all the way back to the wall with the pump running, it makes a similar noise. It has something to do with the back pressure, I guess.
    20K inground gunite w/ Aqua Logic automation and chlorination Sta-Rite 400 K natural gas heater and cartridge filter 2 HP pump 1.5 HP spa bubbler for spillover spa 1 HP dedicated Letro Legend cleaner
    H2O: two parts Heart and one part Obsession. ~Author Unknown

  3. Back To Top    #3

    Join Date
    Jun 2013
    Location
    Dallas, TX
    Posts
    105

    Re: Booster Pump Making Strange Noise (Video)

    Hmm. I did have the fountains running at the same time. Never done that before. I'll check and see if that's the issue.
    35k gal, sand, IG, diamond brite, Hayward Goldline T-CELL-15 Turbo SWG, Aquarite, Compool Lx3600

  4. Back To Top    #4

    Join Date
    Jun 2013
    Location
    Dallas, TX
    Posts
    105

    Re: Booster Pump Making Strange Noise (Video)

    Yup, it was the fountains. Looks like any additional loss of pressure on the main line while running the booster pump is a bad thing. Thought I had a bad pump for a second, but that's all it was.
    35k gal, sand, IG, diamond brite, Hayward Goldline T-CELL-15 Turbo SWG, Aquarite, Compool Lx3600

  5. Back To Top    #5

    Join Date
    Jun 2013
    Location
    Dallas, TX
    Posts
    105

    Re: Booster Pump Making Strange Noise (Video)

    I spoke to soon. This morning could hear the booster pump running and making the same horrible noise from inside the house. Did some googling and found a few places that mention a noisy pump is a sign for replacement. Sticker shows it to be a 2002 model. How long do these usually last?
    35k gal, sand, IG, diamond brite, Hayward Goldline T-CELL-15 Turbo SWG, Aquarite, Compool Lx3600

  6. Back To Top    #6

    Join Date
    Jul 2007
    Location
    Rockville, CA
    Posts
    99

    Re: Booster Pump Making Strange Noise (Video)

    I think eleven years of service would be about the limit of most pumps. I suppose you could try to replace parts, but you may find a new one to be less costly to run and more relaible. As to size, it sounds as though you have varied demands. I can't comment on matching horse power and electrical demand. Sorry it didn 't work out.
    20K inground gunite w/ Aqua Logic automation and chlorination Sta-Rite 400 K natural gas heater and cartridge filter 2 HP pump 1.5 HP spa bubbler for spillover spa 1 HP dedicated Letro Legend cleaner
    H2O: two parts Heart and one part Obsession. ~Author Unknown

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •