Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: De powder back in pool at skimmer and back wash hose water

  1. Back To Top    #1

    Join Date
    Aug 2012
    Location
    Atlanta, GA (Dunwoody)
    Posts
    57

    De powder back in pool at skimmer and back wash hose water

    I am getting de powder back in pool at both skimmers , and I think bottom floor returns and when the pump is running a small continuous amount of water is coming out of the back wash hose. I'm thinking that the pentair multi port valve gasket is the problem? However this did start after breaking down the filter and cleaning. Bled filter valve, no air pockets in pump filter.
    Heinsite
    17500 pool/spa iAqualink Rev R, Pentair DE Filter, Waterfall, 3900 Polaris Cleaner, Goldline Saltwater Gen. w/t15, Rayvac 40,000 Gas heater, Taylor K-2006 Test Kit, Taylor Saltwater Test Kit

  2. Back To Top    #2

    Join Date
    Aug 2012
    Location
    Atlanta, GA (Dunwoody)
    Posts
    57

    Re: De powder back in pool at skimmer and back wash hose wat

    Image below
    Attached Images Attached Images
    Heinsite
    17500 pool/spa iAqualink Rev R, Pentair DE Filter, Waterfall, 3900 Polaris Cleaner, Goldline Saltwater Gen. w/t15, Rayvac 40,000 Gas heater, Taylor K-2006 Test Kit, Taylor Saltwater Test Kit

  3. Back To Top    #3

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,083

    Re: De powder back in pool at skimmer and back wash hose wat

    Sure sounds like the multi-port. You or a service person will have to disassemble it and inspect. Damage to the spider gasket inside is usually the culprit and very obvious.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  4. Back To Top    #4

    Join Date
    Aug 2012
    Location
    Atlanta, GA (Dunwoody)
    Posts
    57

    Re: De powder back in pool at skimmer and back wash hose wat

    UPDATE: Seems that the spider gasket fixed the problem...I do not have water leaking from my backwash hose anymore! not sure if I fixed the DE Powder problem, but guessing I have. I don't have a good vacuum on a pole..I'll be ordering one soon. My next project this weekend is rebuilding my Polaris impeller seal...I have almost rebuilt every component of my pool system in the last year...A pool is more maintenance than my boat! I enjoy doing the projects, but hate spending the money..This website and everyone's help has saved my a lot of money. Thanks to all who have helped or posted their situations for other to learn.
    Heinsite
    17500 pool/spa iAqualink Rev R, Pentair DE Filter, Waterfall, 3900 Polaris Cleaner, Goldline Saltwater Gen. w/t15, Rayvac 40,000 Gas heater, Taylor K-2006 Test Kit, Taylor Saltwater Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •