Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: The spa jets aren't spinning

  1. Back To Top    #1

    The spa jets aren't spinning

    Spa is about 7 years old. Of the 6 jets, 3 spin freely, but the other 3 don't. They move if I manually spin them, but then they stop right away. Is it possible to replace them? Are they just spun onto the pvc, or are they embedded into the pebbletech and can't be replaced?
    30,000 gal salt with spa; built 2006; Jandy 2 hp single speed Stealth; 48 sf Pentair DE filter; Pentair 4 wheel cleaner; Jandy 1400 SWG and 1400PLC salt cell. New filter grids, cleaner pump.

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,489

    Re: The spa jets aren't spinning

    Most spinners can be replaced. Just unscrew them. But it could be a reduction in flow rate that is causing the problem. Have you backwashed the filter recently?
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  3. Back To Top    #3

    Re: The spa jets aren't spinning

    Thanks, Mark. Yes, the filter is clean. When I spin those spinners by hand, they don't go freely. They feel like they've aged or warped or something. Just not an even spin. I may take one off and see if there is anything keeping it from spinning.
    30,000 gal salt with spa; built 2006; Jandy 2 hp single speed Stealth; 48 sf Pentair DE filter; Pentair 4 wheel cleaner; Jandy 1400 SWG and 1400PLC salt cell. New filter grids, cleaner pump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •