Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: New Hayward pump and filter,Turbo Clean pop up question

  1. Back To Top    #1
    Wildcat's Avatar
    Join Date
    Jun 2013
    Location
    Tucson, AZ
    Posts
    308

    New Hayward pump and filter,Turbo Clean pop up question

    Just had an Ecostar VS and 425 sq ft cartridge installed. I will be posting some observations and questions as I go thru my learning curve with the new system.

    First, it is quiet. Very quiet. At 1700 rpm,will soon try it at 1000 rpm. Need to clean up the water after being down for 5 days and running it at higher rpms on a couple of different settings for a while.

    Now a question. I have a Turbo Clean popup system. With the old Sta Rite the jets would pulse as they worked. Now the water just shoots in continuous stream. Had a new top to the Turbo Clean put on today. Was the old pump the cause of the pulse? Was it a good thing or did it mean the system had air in it or something else? Cannot see how a mew top would change anything.Anyone have a Turbo Clean?


    Oh, and the pump as an auto sensing priming feature. I think I have seen some older posts with people having trouble with priming on this pump, maybe they figured it out recently.
    10000 Gal, IG Pebbletec, pop up cleaners,Hayward EcoStar VS, 425 sq ft Hayward Cartridge, waterfall feature

  2. Back To Top    #2
    Wildcat's Avatar
    Join Date
    Jun 2013
    Location
    Tucson, AZ
    Posts
    308

    Re: New Hayward pump and filter, Turbo Clean pop up question

    At 1150 rpm the pressure gauge is showing less than 2 psi. Is that even doing anything to filter the water?
    10000 Gal, IG Pebbletec, pop up cleaners,Hayward EcoStar VS, 425 sq ft Hayward Cartridge, waterfall feature

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •