Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 16 of 16

Thread: Returns seem weak

  1. Back To Top    #1

    Returns seem weak

    I am new here so please be gentle. I have a 16x32 igp with Hayward 1-1/2 max flo pump. my guage reads 40 psi but returns seem weak. they are hardly seem to be moving water. I have already cleaned the filter. any suggestions?

  2. Back To Top    #2

    Join Date
    Feb 2008
    Location
    Denton, TX
    Posts
    5,061

    Re: Returns seem weak

    Welcome to TFP!

    What kind of filter do you have? 40 psi seems incredibly high. What was your pressure before you cleaned your filters?

  3. Back To Top    #3

    Re: Returns seem weak

    its a Hayward de3620 the psi was same, about 38-40

  4. Back To Top    #4

    Join Date
    Jun 2013
    Location
    SpringHill FL
    Posts
    415

    Re: Returns seem weak

    Sounds like a clogged filter........and those filters are only rated up to 50 psi i believe. Before you have a catastrophic failure you may want to open up the housing and manually clean the grids and or give them a overnight soak in detergent then acid bath
    Nathan
    15x30 gunite 18k gallons Hayward star clear plus 120sqft cart

  5. Back To Top    #5

    Re: Returns seem weak

    I ran the filter without cartridge just to see the difference and it made NO difference stayed at 38 psi

  6. Back To Top    #6

    Join Date
    Jun 2013
    Location
    SpringHill FL
    Posts
    415

    Re: Returns seem weak

    Wait you have a cartridge filter? I thought you had a DE filter. Anyway does your gauge read zero when you shut the pump off?(the gauge is functioning properly)?
    Nathan
    15x30 gunite 18k gallons Hayward star clear plus 120sqft cart

  7. Back To Top    #7

    Re: Returns seem weak

    maybe I used the wrong terminology. I took out the piece inside the filter that looks like pcs of screening. it reads 0 when off then climbs to 38 I also have an inline chlorinator. when I put on the water slide the psi drops 2 psi

  8. Back To Top    #8

    Join Date
    Jun 2013
    Location
    SpringHill FL
    Posts
    415

    Re: Returns seem weak

    Ok what does your filter normally run for a psi?Its starting to sound like you have a clog some where.
    Nathan
    15x30 gunite 18k gallons Hayward star clear plus 120sqft cart

  9. Back To Top    #9

    Re: Returns seem weak

    This might sound stupid but I never took notice until recently. Sorry

  10. Back To Top    #10

    Join Date
    Jun 2013
    Location
    SpringHill FL
    Posts
    415

    Re: Returns seem weak

    Is this a new to you pool? When have you known to backwash in the past?
    Nathan
    15x30 gunite 18k gallons Hayward star clear plus 120sqft cart

  11. Back To Top    #11
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,198

    Re: Returns seem weak

    Have you cleaned out the pump strainer pot?
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  12. Back To Top    #12

    Join Date
    May 2013
    Location
    NJ
    Posts
    114

    Re: Returns seem weak

    The filter shouldn't be an issue being you removed the DE grid and still had the same high pressure. Sure sounds like some kind of restriction downstream from the filter. Any restrictions before the pump should lower your pressure at the filter, not raise it. You mentioned an inline chlorinator. Some, like Hayward, restrict the opening down to close to 1/2" where the flow goes through the chlorinator. I had a check valve that used to break about every 2 years and get stuck right there. I since replaced the check valve with a Jandy and replaced the chlorinator with a Pentair 320 which has full flow through the chlorinator. How hard is it to bypass your chlorinator to eliminate it as a potential problem? After that it's all just pipe to your pool. How many returns?
    17x37 IG vinyl, Grecian style, 20k gal, Hayward DE4800, Hayward Super Pump II 1 hp, Rainbow 320 Chlorinator, 6 Vortex 4x10 solar panels, Aquabot Turbo, Dolphin M5, loop-loc mesh cover

  13. Back To Top    #13

    Re: Returns seem weak

    Thank you for your help. It turns out the gauge was bad. It now reads 22psi. I guess that's much better

  14. Back To Top    #14

    Join Date
    Jun 2013
    Location
    SpringHill FL
    Posts
    415

    Re: Returns seem weak

    Good to hear. Glad you got it figured out. My filter runs right around 20 so i think your in good shape. Are you getting weak flow from your jets still?
    Nathan
    15x30 gunite 18k gallons Hayward star clear plus 120sqft cart

  15. Back To Top    #15

    Re: Returns seem weak

    Yes. I got some opinions from neighbors. Whom bye the way are all "experts" at everything. Lol. But it seems I have 6- 90 elbows on the outlet side of filter. I was told there might be friction loss there and to repipe everything to minimize elbows. Does that make any sense?

  16. Back To Top    #16

    Join Date
    Jun 2013
    Location
    SpringHill FL
    Posts
    415

    Re: Returns seem weak

    6 in plain sight? Seems excesive do the pipes resemble the board game " mousetrap" ? Lol. But yes every time the pipe turns 90 degs you do lose flow from friction( the exact amount i dont know)
    Nathan
    15x30 gunite 18k gallons Hayward star clear plus 120sqft cart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •