Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Pump Won't Prime

  1. Back To Top    #1

    Pump Won't Prime

    So yesterday my wife closed the valve to the deck jets and did not open any of the other returns to the pool. This resulted in the pump running for 6 hours with no where for the water to go. When I saw this I opened the valve to the main returns and the pump ran fine. The basket was warm to the touch but since it was pumping I thought all was OK. This morning I went out to start the pump before leaving for work and the pump basket was empty? The pump would not prime. I put a garden hose in the basket and filled it up. It pumped the water out but than nothing, no prime, no pressure in the filter. Any suggestions at what to look for first. The pump is a 1HP super pump about 1 month old

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,333

    Re: Pump Won't Prime

    It could have gotten hot enough to warp something. Hopefully it nothing serious. The first thing to try is resealing the drain plugs on the pump basket. Then clean and lube the basket lid o-ring well. If that doesn't fix it start looking at the fittings, starting at the pump basket suction.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: Pump Won't Prime

    Thanks for the response I'll take a look at the o-rings first. I'm thinking that the intake fitting may be the culprit. I figured dead heading with water is better than running it dry. The pump/motor sounds fine but there must be a leak somewhere.

  4. Back To Top    #4

    Re: Pump Won't Prime

    Turned out that the Teflon tape on the inlet and outlet fittings had melted more or less leading to the failure. With the tape replaced I'm now back up and running. I'm glad the pump was not damaged.

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,333

    Re: Pump Won't Prime

    Glad it was an easy fix!
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •