Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: HELP - pump quit

  1. Back To Top    #1

    Join Date
    Apr 2009
    Location
    South Texas
    Posts
    177

    HELP - pump quit

    I was trying to hook up a vacuum and turned the pump off cuz there was air in the hose. When I tried to turn it back on it hums like it always does but the water doesn't start circulating. Any thoughts what I can check? My water is sparkling but I was just starting shock process cuz my cc is at 1. If I don't get it working I'm going to have a full blown algae outbreak. The pump is 6 days past a year old and I'm guessing had a 1 year warranty. Go figure. Please oh wise ones help me. Thank you!
    Just bought a new house in the country, no pool yet. :(
    Hot tub..500 gals..bromine
    TF100 test kit and speedstir

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: HELP - pump quit

    There are a couple of things to check. Did you go through the whole priming the pump sequence? It sounds like you got air in the pump, which means re-priming.

    Make sure the motor shaft turns freely when the motor is off. If there is resistance to turning, something is probably jamming the impeller.

    Sometimes a sharp bump on the motor will release a stuck starter switch.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Apr 2009
    Location
    South Texas
    Posts
    177

    Re: HELP - pump quit

    The pump basket was full of water and primed. I tried the sharp bump but no luck. I called the pool company and they said if I bought it in June they'd warranty it no matter what, but before removing it to bring it in they said to try a screw on the back side and turn it counter clockwise with the pump turned on. If it's clogged that will blow it out. That did the trick. Whew. Crisis averted. Thanks again!
    Just bought a new house in the country, no pool yet. :(
    Hot tub..500 gals..bromine
    TF100 test kit and speedstir

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •