Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Intellitouch comm problems

  1. Back To Top    #1

    Intellitouch comm problems

    I was wondering if someone can help me with a very strange issue. I have an intellitouch controller that Iím trying to setup to communicate with my intelliflow pump and a Hayward salt system, all controlled through screenlogic2. When I unhook the intelliflow and the chlorinator from the comm port, the screenlogic2 works, I can turn the pump, chlorinator, lights on using screenlogic2. When I hook them back in, I get a screen telling me ďcommunicating with controller please waitĒ and thatís it. Before getting the intelliflow, this setup worked with a superflow pump. I would see output from the chlorinator telling me how much salt is in the water and how much chlorine itís generating. Now I canít get the communication going even when I unhook the intelliflow from the comm port. The intellitouch is still under warranty so Iíll get a replacement if I canít figure this out. Thank you in advance for the help

  2. Back To Top    #2

    In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Silicon Valley, CA

    Re: Intellitouch comm problems

    Intelliflow pump needs to have power to it all the time (right to the breaker). And the screen logic needs to know you have an intelliflow hooked up to it. if you had the pump turned off while trying to communicate with the intelliflow, screen logic wouldn't see it.
    Factory Warranty Station for:
    Jandy, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts