Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Intex model 5667 sand filter flow feels weak

  1. Back To Top    #1

    Join Date
    Jun 2013
    Springfield, IL

    Intex model 5667 sand filter flow feels weak

    I just hooked up my sand filter pump tonight. I am a newbie, so I am not sure how it should be working. Everyone says they are so powerful, so I think something may be wrong. I don't feel much suction on the intake valve inside the pool. I also don't see water flowing in my filter basket. So I am wondering if I might have an air bubble in there like you talked about.

    So should I have a lot of suction on the intake valve when I place my hand over it? And should I be seeing water flowing in the filter basket under the clear lid?

  2. Back To Top    #2

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Sebring, Florida

    Re: Intex model 5667 sand filter flow feels weak

    What is your filter pressure? Is there air in the pump basket? A picture of how your pipes are connected might help.
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3

    Join Date
    May 2012
    Baltimore, Maryland

    Re: Intex model 5667 sand filter flow feels weak

    I just hooked mine up today. when you filled the sand tank did you fill the tank with water? this will help the filter prime.

    what I did was put a bag of sand in the tank filled with water to top of sand, added second bag of sand and filled to top of sand and leveled all sand out. installed the 6 way valve hooked hoses up, opened valves at pool and switched 6 way valve to backwash setting. didnt turn pump on yet, waited till water was coming out of waste of 6 way valve then fired pump up ran backwash until water and sight glass where clear, shut pump off, switched valve to rinse, ran for a min or two. turned pump back off and switched to filter setting and turned pump back on.

    there should be little to no bubbles in the pre-filter basket area when pump is at full prime. make sure ur valves are fully open all your inlet connections are tight and you have no restrictions at the inlet on the pool side.

    if your still having trouble with getting a good prime you could close your inlet and return, remove the hose at the 6 way valve inlet from pump and open the inlet at pool to purge the air from pump line. re-attach the hose to the 6way valve and should get good prime fast
    15'x4' Metal Frame Intex (new this year) 16" 2650gph intex sand filter, 1000gph intex pump (heater) Solar Cover TF-100 testkit, TFPC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts