Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pool pump prime problem

  1. Back To Top    #1

    Pool pump prime problem

    Last night I tried our barracuda for the first time and in order to generate enough suction I had to half close the main drain valve. I let it run for about three hours then when I was done I just pulled the barracuda insert out of the skimmer valve and returned the main drain to fully open. The pump continued to run on filter while I put away the cleaner. After a while I noticed air bubbles coming from one of the three returns and the pump basket had a lot of bubbles on it. I tried turning off the pump and putting the lid off and on but that hasn't seemed to work.

    Today I turned the pump on again and same thing, air in pump basket and bubbles from same return.

    Is this connected at all to my use of the barracuda and turning the main drain half off? Any thoughts or ideas?

    Thanks in advance for any help
    In ground, 19K gallons, hayward sand filter, Zodiac DuoClear SWG, Vinyl liner, South of Toronto, Solar Blanket only

  2. Back To Top    #2

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Sebring, Florida

    Re: Pool pump prime problem

    You have a suction side air leak. Somewhere between the pump and the skimmer(s), air is being sucked into the system. Find that leak and your issues will be solved.
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts