Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Titan Heat Pump won't come out of defrost mode - any advice?

  1. Back To Top    #1

    Titan Heat Pump won't come out of defrost mode - any advice?

    I have a Titan Titanium III heat pump that has gone into defrost mode.
    The manual says the condition will clear itself when the pipes are clear of condensation, but that isn't happening.
    My local supplier has no idea why. I called the manufacturer and tey haven't returned my calls.
    Any advice would be appreciated.
    Thanks.
    (Rental Home) 17k Gallon, Fiberglass In-ground, Hayward 1.5HP Single Speed, Cartridge Filter, Kreepy Krawly Pool Cleaner

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Titan Heat Pump won't come out of defrost mode - any adv

    It is kind of a long shot, but if you haven't already, try turning the circuit breaker off and then back on again and see if that makes any difference.

    If that isn't it, the sensor that detects frost is probably broken.

    I'm assuming of course that it has had plenty of time to warm up and melt any actual frost.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: Titan Heat Pump won't come out of defrost mode - any adv

    Yeah, I tried shutting the breaker off for a while and ran the pump for a few hours on a nice warm day.
    No luck.
    I guess I need to find a dealer or someone that can supply the sensor.

    btw, great site you guys have here. Lots of interesting discussions and good advice.
    (Rental Home) 17k Gallon, Fiberglass In-ground, Hayward 1.5HP Single Speed, Cartridge Filter, Kreepy Krawly Pool Cleaner

  4. Back To Top    #4
    gonefishin's Avatar
    Join Date
    Apr 2007
    Location
    Joliet, Il.
    Posts
    413

    Re: Titan Heat Pump won't come out of defrost mode - any adv

    Hi ghcanuck!

    I am not qualified to give repair/troubleshooting advice on HeatPumps. But I would raise the question...have you had the freon level checked?


    If the freon levels are low, you may notice excessive condensation on the evaporator coils, and they may possibly be getting iced up a bit. I know that I've gone through this with our old home A/C unit...evaporator coils were a frozen block of ice when I finally realized what the problem was.

    Good luck!
    Dan
    33' Aqua-Leader AGP
    Hayward cartridge filter and IntelliFlo VS pump.
    Solar Heat coming ; used to own Aqua-Cal HeatWave 100k (HeatPump)
    Aqua-Rite t-15 SWG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •