Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: filter will not prime

  1. Back To Top    #1

    filter will not prime

    Hi New to this site but have been fixing my pool for a couple of years now but I am stuck. I had a leak in my pvc pipe and I fixed it this year. I checked for any other leaks but I do not see any I have tested all the pipes with dawn and I do n ot see any bubles. My Hayward crystal clear II will not prime it trys to but will not prime. I have cleaned the de filter and lubed all the o rings. Help!! Oh one more thing after I cleaned the filter and replaced the de at the end of the de going through into the filter some of it went into the pool>

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,490

    Re: filter will not prime

    Welcome to the forum!

    Are you saying the pump attached to the filter is not priming?

    Is the pump basket full of water?

    What is the pressure of the filter?

    Did you recently vacuum the pool and is that when this started?

    Check all your valve settings to make sure you don't have a suction port shut off.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  3. Back To Top    #3

    Join Date
    Jun 2012
    Location
    Louisiana
    Posts
    47

    Re: filter will not prime

    I just experienced something that may be the same problem you're having. My problem turned out to be the impeller on the pump. It was the original one; all plastic. It was replaced with a new one, with metal threads, and that solved the problem.
    25,000 gal Plaster; Hayward 1 hp Super II; Hayward Vari-Flo XL Filter

  4. Back To Top    #4

    Re: filter will not prime

    To answer the questions first
    Are you saying the pump attached to the filter is not priming? yes
    Is the pump basket full of water? YES

    What is the pressure of the filter? 0 no pressure

    Did you recently vacuum the pool and is that when this started? no just started it up for season cannot prime so I cannot vacuum.

    Check all your valve settings to make sure you don't have a suction port shut off. where are they what am I looking for???

  5. Back To Top    #5

    Re: filter will not prime

    I believe the pump is good it is trying very hard to prime.

  6. Back To Top    #6

    Join Date
    Jun 2012
    Location
    Louisiana
    Posts
    47

    Re: filter will not prime

    Please don't take this the wrong way, but that's what my wife said. I was at work offshore when we ran into the problem. I tried to troubleshoot it over phone with her. Hopefully your problem is easier to fix than mine.
    25,000 gal Plaster; Hayward 1 hp Super II; Hayward Vari-Flo XL Filter

  7. Back To Top    #7

    Re: filter will not prime

    so how do I check this?

  8. Back To Top    #8
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,490

    Re: filter will not prime

    There might be something stuck in the impeller. Turn off the pump, remove the pump lid and basket. The impeller inlet is on the bottom of the pump basket. Check to make sure there is nothing stuck in there.

    Also post a picture of your pad equipment. That might help and please follow these instructions:

    pool-school/read_before_you_post
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  9. Back To Top    #9

    Re: filter will not prime

    ok I got a shop vac that also is a leaf blower and I put it down the skimmer and blew it out. At first nothing ran it for 1 hour and still would not prime. 2 hours later I go out to see if I could do anything else and I turn it on and it primes. It is not as good a prime as in Previous years I think something is still part way in there do you think it will work its way out?? The pool is circulating now and is blue again. Yea!!

  10. Back To Top    #10
    linen's Avatar
    Join Date
    Jul 2010
    Location
    Twin Cities, MN
    Posts
    8,649

    Re: filter will not prime

    Did you check the impeller?

    You could also try a drain king pushed in to the suction line from the pump side out towards the skimmer.
    TFP Expert who uses Pool School and my TF100 test kit along with PoolMath for my: Round 11K gallon AGP with deep end, 20" sand filter, Matrix 1hp 2spd, 6 2ftX20ft solar panels (and solar cover!), Intex SWCG (copper bars disconnected) and a Rubadub hot tub (chlorine). The SLAM process is not finished until: 1. CC < 0.5 ppm, 2. An OCLT < 1.0 ppm and, 3. The water is crystal clear.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •