Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: New salt water pool problems

  1. Back To Top    #1

    New salt water pool problems

    I just changed my pool to salt water. Every week I am having to clean the cell due to light flashing. The no flow light also comes on frequently. The man that changed it over to salt told me to prime the pool. So I have had to do that several times to get the no flow light off. Now the inspect cell and low salt light is staying on. It will not generate. Even after I added salt, the numbers continue to drop. Any suggestions

  2. Back To Top    #2

    In the Industry

    Join Date
    Dec 2008
    Posts
    82

    Re: New salt water pool problems

    low flow - you need more flow or less turbulent flow. If there's a bend in the pipe close to the cell, the water isn't smooth and might not push that switch in.
    clean cell - if it's actually new you might have incoming power issues, so check those. When cleaning, be sure to fill the cell completely with a 25% acid/water mix for ~15 minutes.
    Salt - get the salt level checked or get some strips. The variance between methods is easily +/- 500ppm, but it will give you an idea. Salt only leaves by dilution.

  3. Back To Top    #3
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: New salt water pool problems

    Welcome to TFP!!!

    Do you actually see white scale build-up on the plates in the cell? If not, then continued acid cleaning is just shortening the life of the cell.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  4. Back To Top    #4

    Re: New salt water pool problems

    There is very little build up on it. I just took the water to a pool store. My salt was 3300 which doesnt match the 1900 reading on the board. They suggested there was either a problem with the cell or board stating that my levels were not low.

  5. Back To Top    #5

    Re: New salt water pool problems

    What do you mean exactly by "light flashing"?

    If you have actually seen sparks, then shut the power off to the SWG immediately, there is something seriously wrong.
    23,000 IG Plaster pool w/ spa, Pentair FNS Plus 48 DE Filter, Hayward RS1000 Main pump, Polaris booster pump, CPSC48 SWG, Legend pool sweep. Dallas, Texas, Full sun, Taylor K-2006

  6. Back To Top    #6

    Re: New salt water pool problems

    The light was blinking then stayed on. The guy that changed it over to salt just came unplugged the board and changed some settings (t3 to t15). Now everything seems fine.

  7. Back To Top    #7
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: New salt water pool problems

    Ah, so the wrong cell size appears to have been set ... assuming you do in fact have the T15.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  8. Back To Top    #8

    Re: New salt water pool problems

    Is a t-15 the right cell for a 38,000 size pool?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •