Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: after pool opening, de and debris in pool return

  1. Back To Top    #1

    after pool opening, de and debris in pool return

    Hi,

    I replaced my filter last year. I had the same company open the pool. While opening the pool, they made a couple of mistakes which I figured out. Yesterday I vacuumed my pool (to waste) for the first time this year. I noticed small debris coming out of the returns. afterwards I backwashed the pool and DE started coming out of the return jets. This morning i had to vacuum again, I noticed small debris again. A little afraid to backwash.

    my guess is there's a hole in the one of the filter panels or they were installed incorrectly. thoughts?

    tia
    37x20, 28,300 gallon gunite, irregularly shaped, hayward 1.5 super pump, hayward 4820 DE filter, northeast geo

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,084

    Re: after pool opening, de and debris in pool return

    What kind of filter do you have? Now would be a good time to enter that info in your sig so you don't have to type it every time.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3

    Re: after pool opening, de and debris in pool return

    thanks, it's a hayward 4820.
    37x20, 28,300 gallon gunite, irregularly shaped, hayward 1.5 super pump, hayward 4820 DE filter, northeast geo

  4. Back To Top    #4

    Re: after pool opening, de and debris in pool return

    I started experiencing the same problem late last year. After noticing a few small tears in sime grids, I replaced all of them just this weekend when I opened the pool. The water is now clear, except for some sediment at the bottom. When I backwash and re-load with DE, white clouds come out of the return jets. What was your issue/remedy?
    ~18K gal, IG gunite, Jandy 1.5 HP pump, Jandy DEL48 filter, Jandy Lite2 400K BTU natural gas heater, Polaris Vac-Sweep 280 w/Century 3/4 HP motor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •