Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Brand New DE filter leaks......o ring?

  1. Back To Top    #1

    Join Date
    May 2013
    Location
    CT
    Posts
    57

    Brand New DE filter leaks......o ring?

    So i ran the filter for the first time yesterday but i notice a small, not steady, but frequent drip coming from the side where the top of the filter housing is. I removed the lock ring, and removed the filter top.

    I inspected the HUGE o ring on the top housing and it was lubed. I reinstalled but same thing.
    Do you guys think its the O ring gasket?

    If i replace the o-ring....what do you use to lube it so the rubber doesnt get eaten away?? I know some lubes will eat rubber.
    18' x 52" AGP 2hp 2 speed pump with Clearwater II 67 GPM DE filter
    200 gallon EZ SPA 1hp 2 speed GREEN pump

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Brand New DE filter leaks......o ring?

    I suggest taking it apart again and examining the area on each piece where they meet the o-ring. The surfaces should be smooth and free of burs or nicks. It doesn't take a whole lot of a bump or grove to provide a path water can get through.

    O-rings should be lubed with a silicone or teflon based plumbers lube. Petroleum based oils will cause problems for the rubber.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    May 2013
    Location
    CT
    Posts
    57

    Re: Brand New DE filter leaks......o ring?

    Thanks, the base has a notch on each side. The top just has a groove that the ring sits in.
    When i remove it i will take pics of the base. It looks like when the top is on, the o -ring should or is supposed to cover the notch to prevent dripping.

    Its weird because both sides of the base has that notch. And one side leaks and the other is not.
    I have the filter on patio blocks which i leveled. If the filter is off SLIGHTLY because the blocks were dead level when installing....would that cause that side to leak?

    I am gonna get a free replacement o ring today and retry with that.
    18' x 52" AGP 2hp 2 speed pump with Clearwater II 67 GPM DE filter
    200 gallon EZ SPA 1hp 2 speed GREEN pump

  4. Back To Top    #4

    Join Date
    Jul 2017
    Location
    Bristol, RI
    Posts
    1

    Re: Brand New DE filter leaks......o ring?

    Hello, did you ever get it fixed? Mines a mess and can't figure out why leaking around the seal with the o ring. Thanks if you can help
    24 foot "Namco" 52 inch pool with 1.5 hp pump and a Clearwater II filter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •