Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aquarite Not generating - lights not on

  1. Back To Top    #1

    Aquarite Not generating - lights not on

    Hi, new to this forum.

    I have had a goldline SWG for 13 years and it has worked well. I am on my 3rd cell and it looks like I need a new one, cleaned it but the "Inspect Cell" light keeps flashing. My question is if there is any generic "cheaper" replacement cells or refurbished cells for my Goldline GLX-Cell-15W Just looked and $529 was the replacement cost.

    23K IG Gunite pool with 3M Quartz Finish, Attached Spa, not currently heated
    Polaris 280 or 380 Pool Cleaner, Cartridge Filter, Variable Speed Pump, Easy Touch Control System

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: Aquarite Not generating - lights not on

    Welcome to TFP!!!

    That light comes on after a set amount of time as a reminder to check the cell. This does not mean anything is wrong with the cell. To reset the light, I think you just hold the Diagnostic button for 3 seconds.

    Why do you think the cell is bad?
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts