Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Adding DE - cloudiness at deep end?

  1. Back To Top    #1

    Adding DE - cloudiness at deep end?

    I added my recommended dose of DE to the skimmer today, and at the bottom of the deep end, started to see a large cloud of white. (What is that thing at the bottom of the deep end called? Looks circular -- what's the name for it?)

    Photo attached, but the cloud was much bigger before I was able to grab my camera. Is this normal? Do I need to do anything unusual?

    [attachment=0:20nis0op]IMG_7140.jpg[/attachment:20nis0op]
    Attached Images Attached Images
    Los Angeles (San Fernando Valley)
    15k gallon in-ground (IG) pool (I believe it's plaster)
    DE filter (Heyward), using cellulose instead of DE
    Jandy APURE1400 3-port salt cell

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Adding DE - cloudiness at deep end?

    I did the same thing a few weeks ago!!!

    Your floor drain is plumbed to the bottom of your skimmer in the 2nd hole. If you poured too fast the heavy DE sunk down the floor drain pipe because all the suction was going through the skimmer. I just put my skimmer float diverter back on with the flap to all floor, and sucked the DE back up (with a little brushing).

    You just need to pour the DE slower and directly into the pipe heading to the pump.

    I had forgotten to turn off my wall suction line, so the skimmer was not pulling as hard as usual and I must have poured it in too fast.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Join Date
    May 2007
    Location
    West Chester, PA
    Posts
    53

    Re: Adding DE - cloudiness at deep end?

    Pretty pool!

    Did you get rid of your cloud? I hope it was just putting in the DE too fast.

    That happened to me, right when I first found this website. Turns out one of my filter baffles had a hole in it (they are inside of the filter housing). So I had to take apart the filter and replace it and the problem was fixed! Doing that really helped me understand the filter system.

    Good luck!
    TF-100 Test Kit, 28,000 gallon IG , 3M quartz plaster '09, 48 sq ft DE filter, Heat Siphon SX5HP heat pump '09, Polaris 360 '10, Protect-A-Child safety fence

  4. Back To Top    #4

    Re: Adding DE - cloudiness at deep end?

    It has since cleared up. That cloud eventually dissipated and I was able to vacuum up some white powder residue at the bottom of the pool (presumably DE). Thanks everybody!

    Admittedly I did pour the DE in very fast this time -- that's the most likely culprit.
    Los Angeles (San Fernando Valley)
    15k gallon in-ground (IG) pool (I believe it's plaster)
    DE filter (Heyward), using cellulose instead of DE
    Jandy APURE1400 3-port salt cell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •