Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Pump o-ring torn

  1. Back To Top    #1

    Join Date
    Jul 2012
    Location
    Illinios
    Posts
    10

    Pump o-ring torn

    Hey guys,

    I was wondering if you could help me out.

    I just opened my pool today and I greases all of the seals. I backwashed, shocked, scrubbed.

    Then I tried filtering. I noticed my Jandy PHPF 1.5 pump wasn't priming. Its self priming. Then it start leaking out from under the top lid. So I thought the O-ring maybe moved on me. I took off the lid and the O-ring was cracked in 2 pcs.

    Now my question is, The pump is working and pushing water pretty good, just won't fully prime.
    Can I keep it running for the next few days until my Orings get here? Or will I burn out the motor?

    Thanks for any help
    2004 - 36'x18' 26000 Gallons - IG-vinyl, Hayward 244t sand filter=300lbs, Jandy HP plus 1-1/2hp pump, Jandy LX-400L heater, Jandy AquaPure1400 Chlorine Generator (salt), Polaris 480 robot

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Pump o-ring torn

    If the pump completely loses prime, which is likely, you will probably damage it fairly badly. If it somehow limps along partially primed it will be alright.

    With a little care and a little luck you can probably arrange the partial O-rings so that the pump fully primes.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Jul 2012
    Location
    Illinios
    Posts
    10

    Re: Pump o-ring torn

    Yep, that worked! I pieced it back together and it's 98% primed now and running. Thanks a ton
    2004 - 36'x18' 26000 Gallons - IG-vinyl, Hayward 244t sand filter=300lbs, Jandy HP plus 1-1/2hp pump, Jandy LX-400L heater, Jandy AquaPure1400 Chlorine Generator (salt), Polaris 480 robot

  4. Back To Top    #4

    Join Date
    Jun 2007
    Location
    New Jersey
    Posts
    653

    Re: Pump o-ring torn

    I have had good success SuperGlue'ing the ends of broken O-rings together to keep things running while I source a replacement.
    Current: 28,000G 18'x36' I/G AnthonySylvan Plaster; Waterway 60 sq.ft. DE Filter; 1.0hp x 1.65 SF Two-Speed (B2982) WhisperFlo; 2004-Present
    Previous: 40,000G 20'x40' I/G Koven unlined WWII salvage 5/8" marine steel; Lomart Stainless Sand Filter; 3/4hp Hayward SuperPump; 1946-2003 (managed by me from about 1964)
    Ancient Taylor K-2000, upgraded with Taylor CH, TA, and FAS-DPD, and TFT CYA tests.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •