Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Aqua Trol RJ not generating!

  1. Back To Top    #1

    Aqua Trol RJ not generating!

    Unit is about 4 yrs old. When I took the cell off and cleaned and stored it for the winter everything was working just fine..

    Hooked everything back up a few days ago and it hasn't worked since! The red no flow comes on when plugged in and blinks for about a minute and then goes off. The the green lite for generating comes on and goes off in about 15 seconds and then nothing. Shows 0 for salt level.

    Tried all the test from this site ... -Guide.pdf everything checked good until I reached step H. When I tested the DSP board I came up with a reading of 1.2

    Thanks for any help you may be able to provide

  2. Back To Top    #2

    Join Date
    Feb 2008
    Flower Mound, TX

    Re: Aqua Trol RJ not generating!

    Welcome to TFP!

    We have a good many Aqua-Trol users here so someone with knowledge of your system should be by soon to help you.
    10K gallon IG gunite with waterfall; Pentair CC320P filter; WhisperFlo 2 HP pump
    TF Test Kits - Pool Math - Pool School
    "It depends."- JohnT

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Aqua Trol RJ not generating!

    Welcome to TFP!

    That sounds kind of like a loose connection between the cell and the control unit.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4

    Re: Aqua Trol RJ not generating!

    Thanks for the welcome guys.

    Checked and rechecked the connection between the cell and control unit and it appears to seat properly!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts