Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Nautilus DE filter Strainer, air vent getting clogged

  1. Back To Top    #1

    Join Date
    Jun 2007
    Location
    Houston, Texas
    Posts
    208

    Nautilus DE filter Strainer, air vent getting clogged

    I'm trying to figure this out. My Nautilus DE filter pressure keeps going up after several hours (5 hours). I've changed the DE grids to new. I've noticed by taking the filter apart that the Air Strainer on top usually gets very clogged with debris (pine needles, bugs, ****, etc) Also the strainer is pressed down flat versus round shape. I bought a new strainer and the same thing happened where it becomes clogged after a few hours and the pressure goes from 18psi (normal) to 30-35psi (high). If I backwash the pressure goes down for a few hours only to go back up after about 5 hours. Because the air strainer is pressed flat, debris gets stuck in it easily. Anybody else experience this?

    The pool is relatively clean, no algae, dirt. theres alot of trees nearby and leaves and needles must be getting trapped. I've installed pool socks and mesh net but somehow debris keeps getting on the air strainer. The DE filter grids look very good. Why would this strainer get clogged, why does it clog so quickly even with skimmer socks and why won't backwashing cure the problem?

    Any help would be appreciated.
    36,000 gallon IG Gunite (40 x 20), 1.5 HP Hayward pump, Pentair Nautilus NS-48 DE filter, 2 skimmers, 12 - (2 x 20) Fafco Solar Panels (Goldline controller not hooked up yet), Hayward Swimpure Plus SWG, Blue Pearl Robot cleaner. New Dr. Wellness X-12 standalone Lifestyle Spa.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879
    If you are having a great deal of pollen right now that could account for it. Pollen can clog up a DE filter quite quickly. Skimmer socks help but they don't catch the really fine pollen.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Jun 2007
    Location
    Houston, Texas
    Posts
    208
    Thanks for the reply. The strange thing is that the DE filter grids are NOT getting clogged. It's only the strainer vent and that's what causing the pressure increase. I used skimmer nets today and it removed some small particles but the pressure still went up. I haven't opened the filter but I'm sure the air strainer is clogged again.

    Anybody experience this? Any ideas how the strainer gets clogged but not the grids?

    Thx
    36,000 gallon IG Gunite (40 x 20), 1.5 HP Hayward pump, Pentair Nautilus NS-48 DE filter, 2 skimmers, 12 - (2 x 20) Fafco Solar Panels (Goldline controller not hooked up yet), Hayward Swimpure Plus SWG, Blue Pearl Robot cleaner. New Dr. Wellness X-12 standalone Lifestyle Spa.

  4. Back To Top    #4

    Join Date
    Jun 2007
    Location
    Houston, Texas
    Posts
    208
    I failed to mention that I replaced my filter grids a few weeks ago with the same Unicel model grids. Apparently something's wrong with the new grids. I used the old grids and there's no pressure problems. I now am using 6 old grids and 2 new grids and so far so good.

    Any idea why the new grids would cause pressure problems? It takes a few hours but the pressure keeps building on the new grids until the filter starts squealing (>35 psi). Did I get a bad batch of filters?
    36,000 gallon IG Gunite (40 x 20), 1.5 HP Hayward pump, Pentair Nautilus NS-48 DE filter, 2 skimmers, 12 - (2 x 20) Fafco Solar Panels (Goldline controller not hooked up yet), Hayward Swimpure Plus SWG, Blue Pearl Robot cleaner. New Dr. Wellness X-12 standalone Lifestyle Spa.

  5. Back To Top    #5
    Very strange. I have never heard of new grids being defective in that way. I would return them for a new set.

    The air strainer plugs because it's the path of least resistance for the water. Not all filters have the air strainer and I've never seen a need for them. Perhaps I'm missing something with them but I found they are just a pain (strainer comes off, DE goes back into pool.

    Let us know what happens with the new grids.

  6. Back To Top    #6

    Join Date
    Jun 2007
    Location
    Houston, Texas
    Posts
    208
    I reinstalled the old filters and no problems at all. Very strange that the new filters gave me problems. I actually have 6 old filters and 2 new ones installed since 2 old filters were cracked.

    The new filters are the same brand but they seem to hold water alot tighter. That could be the problem. Maybe they were wound tighter.
    36,000 gallon IG Gunite (40 x 20), 1.5 HP Hayward pump, Pentair Nautilus NS-48 DE filter, 2 skimmers, 12 - (2 x 20) Fafco Solar Panels (Goldline controller not hooked up yet), Hayward Swimpure Plus SWG, Blue Pearl Robot cleaner. New Dr. Wellness X-12 standalone Lifestyle Spa.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •