Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Sta-Rite SD110

  1. Back To Top    #1

    Sta-Rite SD110

    Hey Gang,

    I have a Sta-Rite SD110 filter for my gunite inground pool. I think it was put in around 2004, so just under 10 years ago. I don't believe the filter grid elements have ever been replaced. They are yellow, but otherwise appear to be holding together. How will I know these things need replacement? I see they are quite expensive, so I don't want to replace them unnecessarily.

    20,000 Gallon Gunite IG Pool w/ AG attached Spa -- Built 2004
    Sta-rite S8D110 DE 106 GPM Filter
    Sta-rite Max-E Pro 3 HP Pump
    Hayward H300 Electric Pool Heater
    Polaris 380 Cleaner

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: Sta-Rite SD110

    If you start seeing dirt passing back into the pool or if your pool will not stay clean, that would point to a problem with the cartridge. Just do a thorough inspection to look for damage or tears. Antother problem would be a build up of calcium cloggin it up.

    Please add your pool details and location as described HERE as it will help us help you.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts