Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pentair Intelliflo pump shuts off when solar starts

  1. Back To Top    #1

    Join Date
    Mar 2013
    Temecula, California

    Pentair Intelliflo pump shuts off when solar starts

    We moved to a new house with our first pool, and we just added solar hot water, saltwater generator, and Pentair VS-SRVS pump. Work was all completed by the solar installer last week. The SWG system was installed but will be set up with salt later this week. (Previously had Rainbow chlorination system.) Right away after last week's install we noticed two problems. First, when solar is supposed to kick on and the pump is priming the solar system, that trips the suction alarm and automatically cuts off. Second problem is that the pump was programmed by the solar installer and while the pump is running late in the afternoon after the solar system is off for the day, the pump does not appear to be powering the filter, though the pump at the unit clearly is running.

    For instance right now it is 4 pm and solar is set to be done for the done, and pump says 2700 rpms, but the pool filter is not running. We do have a small waterfall that may just be decorative (?) and that is running but the robotic cleaner is not moving at all and no water in the pool appears to be moving.

    Solar installer had the Pentair rep out here and rep told us the unit, which my husband bought online, is intended for commercial use and not very compatible with solar, and that's the issue. We checked Pentair's site again and nowhere does it say that this unit is commercial or that solar would be a problem. Installer said he's going to talk to Pentair rep again and will get back to us. Anyone have any ideas or experience with this? Thank you.
    Temecula, California (1999), 32K gal, IG plaster, 320 sq ft cartridge filter, Pentair Intelliflo VS-SRVS (model 11017) pump, Zodiac Nature2 Model G inground purifier, pool solar hot water and Riley 400K BTU heater, SWG Pool Pilot DIG-220, spa

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: Pentair Intelliflo pump shuts off when solar starts

    Seems like everything I have seen mentioned here on the forums basically points to having problems with the SRVS portion of that pump when anything "out of the ordinary" is done ... like suction cleaners, vacuuming and now solar?

    When the solar turns on it, will increase the pressure headloss, but should not really affect the suction.

    I am a little confused by your terminology ... whenever the pump is one, water should be flowing through the filter .... not sure what "powering the filter" is supposed to mean.

    Add some pictures of your plumbing/equipment/valves as that may help see an issue.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts