Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Digital pool pilot display not working

  1. Back To Top    #1

    Digital pool pilot display not working

    I have a digital pool pilot. I turned on the power today. The board says to set day and time. I can not get the menu or any buttons to respond. All wires are connected correctly and fuses are fine. I searched this forum to see if anyone else has had this problem, but did not see anything. Any ideas?
    IG 18 x 36 Gunite
    STA-RITE pump
    Trition sand filter
    Middleton,ID
    Dg

  2. Back To Top    #2

    Re: Digital pool pilot display not working

    I have the same exact problem. Anyone know the fix?

  3. Back To Top    #3

    Join Date
    May 2007
    Location
    North Texas
    Posts
    5

    Re: Digital pool pilot display not working

    Mine is stuck on Set time of Day. It did that before and I took the board out and pressed the buttons several times to unstick any that could be and it worked after that. This time though I took it apart 2x and pushed buttons and blew canned air in the buttons and I'm still stuck on Set time of Day. That is exactly what I was doing when they stuck, I was programming the time and pool speeds.
    I noticed a button battery on the computer board I'm assuming its for memory when the unit is off? So someone help!
    I finally got my pool clean and now its stuck on low speed pump, we've been having lots of rain so I wanted to program the high speed to come on more often and do a boost. I can't do anything!
    :grin::grin: Yes I am a newbie :grin::grin:

    Grecian 17'x33' Vinyl liner pool
    ZeoBrite filteration
    SWG Aqua-rite
    Sta-Rite Dura-Glas 1.5hp pump.
    SAM Light

    21037.5 gallons

  4. Back To Top    #4

    Join Date
    May 2007
    Location
    North Texas
    Posts
    5

    Re: Digital pool pilot display not working

    I'm going to remove the button battery tomorrow morning to see if it resets my digital display. Fingers crossed....
    :grin::grin: Yes I am a newbie :grin::grin:

    Grecian 17'x33' Vinyl liner pool
    ZeoBrite filteration
    SWG Aqua-rite
    Sta-Rite Dura-Glas 1.5hp pump.
    SAM Light

    21037.5 gallons

  5. Back To Top    #5

    Join Date
    Apr 2007
    Location
    Ft Lauderdale, Florida
    Posts
    1,455

    Re: Digital pool pilot display not working

    for the "stuck" buttons, please remove the circuit board off the cover and inspect the plastic posts that the board attaches to. If these are broken or cracked, its possible for the board to be pushing away as you try to press the buttons through the cover.
    While the board is removed from the cover, as nbws6 did, fiddle with the buttons to clear any debris that may be preventing the button from making good contact.

    The battery is only there to keep the time when the unit is powered down. When the unit is receiving power, the timer should work properly and should not affect anything else.
    Sean Assam - Sean@teamhorner.com
    National Accounts and Commercial Products Manager
    AquaCal Heat Pumps www.aquacal.com
    AutoPilot Salt Chlorine Generators www.autopilot.com

  6. Back To Top    #6
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Digital pool pilot display not working

    When my previous battery failed, the unit would alternate power ups. Half the time it would give a battery dead error and refuse to continue and half the time it would work normally. So try cycling power to the unit and see if it comes up.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  7. Back To Top    #7

    Join Date
    May 2007
    Location
    North Texas
    Posts
    5

    Re: Digital pool pilot display not working

    I just got done putting it back together. The plastic stands are fine, not broken or cracked. I did press buttons again multiple times but also carefully removed the button battery, kept it out for about a minute. Started it up and its fixed. Not sure if doing the button pushing for the 3rd time or removing the battery fixed it but I'm happy! I programmed the high/low pump with a grin on my face.
    :grin::grin: Yes I am a newbie :grin::grin:

    Grecian 17'x33' Vinyl liner pool
    ZeoBrite filteration
    SWG Aqua-rite
    Sta-Rite Dura-Glas 1.5hp pump.
    SAM Light

    21037.5 gallons

  8. Back To Top    #8

    Re: Digital pool pilot display not working

    I removed the battery and my keypad works again. Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •